Jump to content

Archived

This topic is now archived and is closed to further replies.

learngreektoday

Vsignup (membership script

Recommended Posts

I am starting a e-learning website to teach the Greek Language and am having some trouble with a authenticate/membership script call vSignup. I should let you know off the bat that I am very new at PHP. I have been working with HTML for awhile but just got into server side processing language. Let me give you as much info so it will be easy for you guys to help...

layout:

I have a apache server behind my firewall. I did this so I can develop the site and then go live at a later date. The site is accessible from the internet 

Server(ip 192.168.1.3)
servers installed:
aph,php,MySQL,phpmyadmin
Page dir/
/htdocs(all pages are here)
-->vSignup
-->phpmyadmin
vSignup installation:
1. Launch your database manager (phpMyAdmin) for MySQL and run the createdb.sql file.

2. Modify authconfig.php to match your database settings and your file pathing.

3. Modify auth.php to match your database settings.

4. Modify signup config to match your database settings, file pathing, and administrator email address.


step 1
Done. I see the information in MySQL

Step 2: Modify authconfig.php
[b]// ALL PATHS BELOW ARE RELATIVE TO THE DIRECTORY WHERE YOU HAVE INSTALLED vAuthenticate
$resultpage = "vAuthenticate.php";
$admin = "/vAuthenticate/admin/index.php";
$success = "/vAuthenticate/members/index.php";
$failure = "/failed.php";[/b]
(few lines down)

$[b]changepassword = "http://" . $_SERVER['192.168.1.3'] . "/vSignup/chgpwd.php";
$login = "http://" . $_SERVER['192.168.1.3'] . " /index.htm";
$logout = "http://" . $_SERVER['192.168.1.3'] . "/vSignup/logout.php";
(dbhost, dbusername,dbpassword, and dbname are set.)[/b]

Step 3:Modify auth.php

all info set

step 4: Modify signup config

database info set

[b]$RelLogin = "/index.php";
$confirm = "http://" . $_SERVER['192.168.1.3'] . "/confirm.php";[/b]Thats the config so far.

1st issue is that I can't access the administrator page. It says "after I have config all the pages to go to my the login.php( now my index.php) and enter the default username/password. When I do I get the following msg in my browser:

FORBIDDEN
[i]You don't have permission to access/< on this server.[/i][i]2nd issue is when I try and signup a test user I get this msg:[/i]

Notice: Undefined index 192.168.1.3 in c:\programsfile\apache2\htdocs\vSighup\signupconfig.php on line 39[/I[I]]Notice: Undefined index 192.168.1.3 in c:\programsfile\apache2
\htdocs\vSighup\process.php on line 200
Thank you for signing up!


Now something must be working but I don't see the test user in the database(don't know if I am looking in the correct place) and when I try and login using the test user I get the same msg.

Thank you in advance

P.S I you need access to my server to see any pages or code please send me a private msg....Thanks

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.