Jump to content

[SOLVED] PostgreSql on WampServer


Recommended Posts

I am currently running WampServer 2.0i (Apache 2.2.11, PHP 5.3.0, MySql)

As installed all works great.

I installed PostgreSQL 8.4 listing on port 5432. It works great outside of Apache/PHP

I enabled pdo_pgsql.dll and pgsql.dll in php.ini and restarted Apache. It seems that it is not loading the .dll files as I am getting Fatal Error: undefined function pg_connect, when you try to connect to the database. Also when you look in phpinfo() under PDO drivers it only mentions mysql and sqlite. No mention anywhere about PostgreSQL.


I have been looking around and it seems that this is an issue with WampServer after PHP version 5.2.5 or .6

Does anyone have any suggestions?? I really need to get this working!

Link to comment
Share on other sites

Click on WampServer icon in tray, select PHP > PHP Extensions and mark php_pdo_pgsql. Wait until server restarts itself.




Ok. Just tried it myself, and indeed it doesn't seem to be working. Did you ask at WampServer's forum?

Link to comment
Share on other sites

Ok, got it all working as follows:


I removed the WampServer 2.0i version that I was using and installed WampServer 2.0c in it's place.


I then went to the following site:




This site is in a non English language, so click on the 'Translate' Button on the top right to get it in English.


and get their copies of the following to dll's





place them into your ext directory

enable php_pdo_pqsql.dll and php_pqsql.dll in your php.ini and restart your Apache server.


It worked for me the first time.


I never heard any info from WampServer personnel concerning this issue.


ended up with the following versions of everything:


Apache 2.2.8

PHP 5.2.6

MySQL 5.0.51a

PostgreSQL 8.2.3

Link to comment
Share on other sites


I never heard any info from WampServer personnel concerning this issue.



Their forum is not very busy, and your issue is far from common (after all MySQL is most widely used with WampServer).

Anyway, it would be nice to get any kind of response.

Link to comment
Share on other sites

This thread is more than a year old. Please don't revive it unless you have something important to add.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.