Jump to content

Archived

This topic is now archived and is closed to further replies.

anner

Building RPM error, please help

Recommended Posts

This may be the completely wrong place for this, but I couldn't figure out where it should go...

I'm building an rpm of the newest php (5.1.5) on Redhat ES4 and keep getting this error in the install portion:

[code]apxs:Error: Config file /var/tmp/php-root/etc/httpd/conf/httpd.conf not found.
make: *** [install-sapi] Error 1
[/code]

I can't find any reference to httpd.conf in my spec file.  I think, upon inspection, that my apxs is fine, but I could be wrong.  That file definitely is not there (/var/tmp/php-root/etc/httpd/conf/ is empty).  If I get the spec file to copy it into that dir from the live location (/etc/httpd/conf/httpd.conf), I get the same problem.

I really feel like I am banging my head against the wall, so any pointers would be much appreciated.

My spec file is 500 lines, so I don't want to post the whole thing unless someone specifically asks.  I've tried 2 different ones.  I took a fedora core 5 php 5.1.4 rpm spec file and editted and tried that, and the latest I could find for a RHEL4 rpm, which was 4.2.3.  Both give the identical error in the identical location.  The build does complete, as does the ./configure <args> and make by hand...it's the install part having problems.

Share this post


Link to post
Share on other sites
ok, I did find the right spot in the spec file where I can copy my .conf file over.  And now I'm almost done...then I get this
[code]RPM build errors:
    File not found: /var/tmp/php-root/usr/lib/php/build[/code]

Does this mean I need php-devel to build a php rpm?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.