Jump to content

Archived

This topic is now archived and is closed to further replies.

Babushka

Help me

Recommended Posts

I want to inatall Apache,PHP,MySQL and PMA. PHP works fine, but after I Installed MySQL and used the configuration Wizard I went to the command line and entered: mysql -u root -p ,entered my password,used some functions like use mysql; and show tables; .
Everything seemed to work fine but when I use the phpinfo() function I don't see
a MySQL info (like in the image in this tutorial [url=http://www.kidslovepc.com/php-tutorial/install-php-phpmyadmin.shtml]http://www.kidslovepc.com/php-tutorial/install-php-phpmyadmin.shtml[/url])

Any idea what's the problem or how can I fixed it?
I've read that the problem may be because of the path entry in the environment variables.How should my Path entry look like?

Thanks in advance

Share this post


Link to post
Share on other sites
I've managed to fix that problem by adding php_mysql.dll file to windows directory.
Now  I downloaded PhpMyAdmin and I get this problem when I enter to my pma:

[code]
Warning: require_once(./libraries/common.lib.php) [function.require-once]: failed to open stream: No such file or directory in C:\Program Files\Apache Software Foundation\www\pma\phpMyAdmin-2.7.0-pl2\index.php on line 40

Fatal error: require_once() [function.require]: Failed opening required './libraries/common.lib.php' (include_path='.;C:\php5\pear') in C:\Program Files\Apache Software Foundation\www\pma\phpMyAdmin-2.7.0-pl2\index.php on line 40[/code]
Can u help me?

Share this post


Link to post
Share on other sites
Looks like you havnt extracted/uploaded phpMyAdmin correctly to your server.

Just download the lates phpMyAdmin version from phpmyadmin.net.

Extract the contents of the zip to your servers root directory, the directory in which you place your website files so they are seen from the intranet/internet (htp://localhost/). Now copy a file called config.default.php from phpmyadmin/libraries, to the root of the phpMyAdmin folder. Rename config.default.php to config.inc.php.

Now go to http://localhost/phpmyadmin/

You should now see the phpMyAdmin main screen. If you have a password setup for the root user for accessing MySQL you'll need to edit the config.inc.php and look for the following:
[code]$cfg['Servers'][$i]['auth_type']    = 'config';[/code]
Change config to cookie, save config.inc.php. Now goto http://localhost/phpmyadmin it should now display a login form. Fill in the form and you'll be logged into phpMyAdmin ready to manage your MySQL database

Share this post


Link to post
Share on other sites
I got  phpMyAdmin-2.7.0-pl2 and the config.default.php is already in the phpmyadmin root directory (although it's not in the libraries directory). Is downloading the newest version necessary?
I have
[code]$cfg['Servers'][$i]['auth_type']    = 'config';[/code]
in my  config.default.php but it's still doesn't work.

I get this problem when I enter to pma:
[code]
Warning: require_once(./libraries/common.lib.php) [function.require-once]: failed to open stream: No such file or directory in C:\Program Files\Apache Software Foundation\www\pma\phpMyAdmin-2.7.0-pl2\index.php on line 40

Fatal error: require_once() [function.require]: Failed opening required './libraries/common.lib.php' (include_path='.;C:\php5\pear') in C:\Program Files\Apache Software Foundation\www\pma\phpMyAdmin-2.7.0-pl2\index.php on line 40[/code]

Share this post


Link to post
Share on other sites
You need to rename config.default.php to config.inc.php. Also you shouldnt of moved config.default.php from the libaries folder. So you should have config.inc.php in the roof of the phpmyadmin folder and config.default.php in the libaries folder.

ALso you appear to be using IIS/PWS. Have a read of [url=http://www.phpmyadmin.net/documentation/#faq1_6]this PMA FAQ[/url]

Share this post


Link to post
Share on other sites
I had followed your instructions but nothing changed. Does someone has a PHPMyAdmin tutorial for me? It seems like all the tutorials I find on the net are half explained and full of errors.

Share this post


Link to post
Share on other sites
Try downloading the latest version of phpmyadmin from phpmyadmin.net. 2.7.x is old. The latest version is [url=http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.8.2.4.zip?download]2.8.2.4[/url]

The version of PMA you have is a patch so its most most probably got files missing.

Share this post


Link to post
Share on other sites
I will try that. Thanks a lot. One question:Do I have to change (again) the httpd.conf in the apache directory if I installed PMA in the apache root directory?

Share this post


Link to post
Share on other sites
[quote author=Babushka link=topic=106493.msg426760#msg426760 date=1157228365]
I will try that. Thanks a lot. One question:Do I have to change (again) the httpd.conf in the apache directory if I installed PMA in the apache root directory?

[/quote]
Not sure what you mean there. could you post the part of the httpd.conf in question here. A little confused.

Share this post


Link to post
Share on other sites
I mean, do I have to change something at the server's directories. Like I had to change the http.conf file when I installed php. I mean,What's wrong? What is pma trying to do?

Warning: require_once(./libraries/common.lib.php) [function.require-once]: failed to open stream: No such file or directory in C:\Program Files\Apache Software Foundation\www\pma\index.php on line 36

Is he searching the required file in the index.php itself and not in the pma directory? help

Share this post


Link to post
Share on other sites
No you dont need to chnage anything to the httpd.conf. phpMyAdmin is a PHP script. But what phpMyAdmin is trying to do is include a file called common.lib.php in the libraries folder. Which PHP cannot find and thus results in the the error you are getting.

Did try my suggestion by upgrading phpMyAdmin?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.