Jump to content

Archived

This topic is now archived and is closed to further replies.

almcnicoll

Apache2.2 service starts, but all page requests hang

Recommended Posts

Hi there,

just wondering if anyone else has come across this issue?

I've got Apache2.2 running on a WinXP Pro laptop. Originally it was crashing with a whole load of errors in the error log, and searching on those led me to use the DisableAcceptEx directive. Now the server starts, the Apache Monitor says it's happy, and the error log is clean.

BUT ...

Browsing to localhost or 127.0.0.1 just keeps seeking the page forever! It doesn't timeout the near side of 30 minutes, and there's no entries in the error or access logs. My firewall program (AVG Network Edition) prompted me to allow or deny and I created an Allow rule so it isn't being blocked there...

Last and not least, when including the relevant LoadModule directives to enable PHP, the server refuses to start (they're the standard PHP LoadModule lines, and I installed it in the standard location of c:/php)

Can anyone help? I can give more technical details on request.

Al McNicoll

Share this post


Link to post
Share on other sites
What port is Apache running on, look for the Listen directive, after that should be the port number it is using. If its not port 80. You'll need use this to access your intranet: 127.0.0.1:port_number or just localhost:port_number - eg http://localhost:8080/ if 8080 is what Apache is configured to use that port.

Also PHP isnt compatible with Apache2.2.x. You'll need to download thirdparty PHP modules to get PHP to work with Apache2.2. You can get the modules over at apachelounge.com. Anb eaiser option is to down grade Apache to Apache 2.0.x

PHP is currently only compatible with Apache 1.3.x and Apache 2.0.x. The next release of PHP should support Apache 2.2.x.

Share this post


Link to post
Share on other sites
Thanks for the post.
Apache is running on port 80 - and I get the same behaviour if I explicitly ask for http://localhost:80.

I'd like to find out whether the packets are being blocked somewhere, or whether I've done something to the server to stop it responding correctly - is there a tool I can use to "ping" a specific port?

Thanks for the heads-up on PHP/Apache2.2 - guess I should have checked that before upgrading!

Al

Share this post


Link to post
Share on other sites
Try changing the port that Apache is listening to, such as try port 8888. So find Listen 80 in the httpd.conf change 80 to 8888 save the httpd.conf. Restart Apache. Now goto http://localhost:8888 any difference?

You ping localhost on your computer, by going to Start Run > type in cmd. Click Ok now type in [b]tracert 127.0.0.1[/b].

Share this post


Link to post
Share on other sites
Unfortunately, changing the port number makes no difference. Got the server listening on port 8888 and tried both localhost:8888 and 127.0.0.1:8888 - nada.
tracert gives me a perfect trace (<1ms) for localhost and 127.0.0.1, so I guess the problem isn't there.

Incidentally, I uninstalled 2.2 and reinstalled 2.0 as PHP is essential for me - same problem, so it's not a specific Apache2.2 config problem. I have a working Apache2.0 installation on another (XP home) machine, so I'll try trawling through the config files for differences...

Thanks for your help - if you do have any more ideas, please do let me know!

Al

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.