Jump to content

Archived

This topic is now archived and is closed to further replies.

Poundex

Compiling PHP-GTK2

Recommended Posts

I'm trying to compile PHP-GTK2 Under Ubuntu but keep running into this:

[code]checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.6.0...
*** 'pkg-config --modversion glib-2.0' returned 2.6.6, but GLIB (2.10.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: PHP-GTK 2.x requires GLib 2.6.0 or higher
[/code]

I don't have an /etc/ld.so.conf (just an /etc/ld.so.cache) and LD_LIBRARY_PATH) Isn't set.
Can anyone help, please? Thanks.

Share this post


Link to post
Share on other sites
Did you update your glib libraries recently?

Do a
[code]
locate glib-2.0.pc
[/code]

If you find more than one, then find the one with 2.10.3 listed as the "Version" (You can open it with a text editor), and use the following when you run configure the next time.

[code]
PKG_CONFIG_PATH=/path/to/dir/holding/glib-2.0.pc/ ./configure --etc --etc
[/code]

Note that the path should not include the .pc filename.

If you find only one .pc file and it only refers to the 2.6.x version, then you may be able to simply rename it and run configure again. Now not being able to find the .pc file, configure should just look in the standard locations for the glib libraries and use them.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.