Jump to content


Compiling PHP-GTK2

  • Please log in to reply
2 replies to this topic

#1 Poundex

  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 10 September 2006 - 06:52 PM

I'm trying to compile PHP-GTK2 Under Ubuntu but keep running into this:

checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.6.0...
*** 'pkg-config --modversion glib-2.0' returned 2.6.6, but GLIB (2.10.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error: PHP-GTK 2.x requires GLib 2.6.0 or higher

I don't have an /etc/ld.so.conf (just an /etc/ld.so.cache) and LD_LIBRARY_PATH) Isn't set.
Can anyone help, please? Thanks.

#2 shoz

  • Staff Alumni
  • Advanced Member
  • 600 posts

Posted 10 September 2006 - 09:03 PM

Did you update your glib libraries recently?

Do a
locate glib-2.0.pc

If you find more than one, then find the one with 2.10.3 listed as the "Version" (You can open it with a text editor), and use the following when you run configure the next time.

PKG_CONFIG_PATH=/path/to/dir/holding/glib-2.0.pc/ ./configure --etc --etc

Note that the path should not include the .pc filename.

If you find only one .pc file and it only refers to the 2.6.x version, then you may be able to simply rename it and run configure again. Now not being able to find the .pc file, configure should just look in the standard locations for the glib libraries and use them.

#3 karthikeyan_coder

  • Members
  • PipPipPip
  • Advanced Member
  • 201 posts

Posted 14 September 2006 - 08:01 PM

just install GLib 2.6.0 and compile again

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users