Jump to content


Photo

syntax error


  • Please log in to reply
28 replies to this topic

#21 JayBachatero

JayBachatero
  • Members
  • PipPipPip
  • Advanced Member
  • 296 posts
  • LocationQueens NY

Posted 05 October 2006 - 08:02 PM

Ok for the
while ($row = mysql_fetch_row($result))
.  It should be just one set of mysql_fetch_row() not two mysql_fetch_row(())
JayBachatero
SMF Developer && Converter Specialist

#22 gBase

gBase
  • Members
  • PipPipPip
  • Advanced Member
  • 32 posts

Posted 05 October 2006 - 08:10 PM

lol...good catch, took those out but I'm still getting the same error...
???

#23 JayBachatero

JayBachatero
  • Members
  • PipPipPip
  • Advanced Member
  • 296 posts
  • LocationQueens NY

Posted 05 October 2006 - 08:17 PM

You changed this line
$request = mysql_query("SELECT ID, Name, Organization, Title, Street, City, State, Zip FROM table01 WHERE ID LIKE '%$_POST['Name']%'");
to this
$request = mysql_query("SELECT ID, Name, Organization, Title, Street, City, State, Zip FROM table01 WHERE ID LIKE '%$_POST[Name]%'");
?
JayBachatero
SMF Developer && Converter Specialist

#24 gBase

gBase
  • Members
  • PipPipPip
  • Advanced Member
  • 32 posts

Posted 05 October 2006 - 08:25 PM

Ok, cool...now it works (sort of.)  it displays the correct fields (ID, Name, Organization, etc.) but with no values attached to them, not matter what name I search for.  Any thoughts?

In other words, I get:
ID:
Name:
Organization:
Title:
Street:
City:
State:
Zip:

#25 JayBachatero

JayBachatero
  • Members
  • PipPipPip
  • Advanced Member
  • 296 posts
  • LocationQueens NY

Posted 05 October 2006 - 08:33 PM

while ($row = mysql_fetch_row($result)) -> while ($row = mysql_fetch_row($request))
JayBachatero
SMF Developer && Converter Specialist

#26 gBase

gBase
  • Members
  • PipPipPip
  • Advanced Member
  • 32 posts

Posted 05 October 2006 - 08:54 PM

Thanks, tried that but still getting same output when I search.

#27 fenway

fenway
  • Staff Alumni
  • MySQL Si-Fu / PHP Resident Alien
  • 16,199 posts
  • LocationToronto, ON

Posted 05 October 2006 - 08:55 PM

At this point, you could have re-written the entire 10-line script already....
Seriously... if people don't start reading this before posting, I'm going to consider not answering at all.

#28 gBase

gBase
  • Members
  • PipPipPip
  • Advanced Member
  • 32 posts

Posted 06 October 2006 - 12:17 AM

At this point, you could have re-written the entire 10-line script already....


Do I need to?  I was under the impression I had something that was pretty close to working.

#29 fenway

fenway
  • Staff Alumni
  • MySQL Si-Fu / PHP Resident Alien
  • 16,199 posts
  • LocationToronto, ON

Posted 06 October 2006 - 01:12 PM

I was referring to collective time spent on debugging each line... but yes, it does sound like you're quite close.
Seriously... if people don't start reading this before posting, I'm going to consider not answering at all.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users