Jump to content


Photo

Need Help


  • Please log in to reply
7 replies to this topic

#1 jana

jana
  • Members
  • PipPipPip
  • Advanced Member
  • 35 posts
  • LocationIndia

Posted 07 October 2006 - 07:14 AM

i am new to php. i hav installed wamp and created a simple script tst.php as

<?php
echo "hello world";
?>
on machine (10.0.0.1) and worked fine on this machine when i tried the same script on 10.0.0.2 as (http://10.0.0.2/tst.php)
an error apperas as

"Forbidden

You don't have permission to access /tst.php on this server.
Apache/2.0.59 (Win32) PHP/5.1.6 Server at 10.0.0.1 Port 80
"

can anyone tell me how to solve this?
Jana

#2 tleisher

tleisher
  • Members
  • PipPipPip
  • Advanced Member
  • 88 posts

Posted 07 October 2006 - 03:21 PM

Make sure your CHMOD settings are set to at least 666.

#3 jana

jana
  • Members
  • PipPipPip
  • Advanced Member
  • 35 posts
  • LocationIndia

Posted 09 October 2006 - 03:40 AM

where i can find the chmod settings?
Jana

#4 tomfmason

tomfmason
  • Staff Alumni
  • Advanced Member
  • 1,696 posts
  • Locationstealing your wifi

Posted 09 October 2006 - 03:52 AM

Windows has no CHMOD to set. Do you have two machines or ?? because each one of those ip's that you posted would be a different machine. Unless you have set up another virtual ip for that particular directory.

Good Luck,
Tom

Traveling East in search of instruction, and West to propagate the knowledge I have had gained.

current projects: pokersource

My Blog | My Pastebin | PHP Validation class | Backtrack linux


#5 jana

jana
  • Members
  • PipPipPip
  • Advanced Member
  • 35 posts
  • LocationIndia

Posted 09 October 2006 - 10:12 AM

yes, i do hav more than 10 machines interconnected via LAN.
Jana

#6 tomfmason

tomfmason
  • Staff Alumni
  • Advanced Member
  • 1,696 posts
  • Locationstealing your wifi

Posted 09 October 2006 - 10:35 AM

Ok then. You will, most likely need to change your vhost configuration in the http.conf. Instead of having something like this.

<VirtualHost *:80>
ServerName localhost
DocumentRoot "C:\wamp\www"
</VirtualHost>

change * to the ip on the local network of the server.
also make sure that you do not have it set to listen like this.

LISTEN localhost:80

rather
Listen 80

That should fix the problem.

Hope that helps,
Tom

Traveling East in search of instruction, and West to propagate the knowledge I have had gained.

current projects: pokersource

My Blog | My Pastebin | PHP Validation class | Backtrack linux


#7 tomfmason

tomfmason
  • Staff Alumni
  • Advanced Member
  • 1,696 posts
  • Locationstealing your wifi

Posted 09 October 2006 - 10:41 AM

If you have the newest version of wamp then disregard my previous post had make the following changes to the http.conf.

ServerName localhost:80

localhost should be changed with the ip address of the server

and in:

<Directory "C:/wamp/www">

#
# Possible values for the Options directive are "None", "All",
# or any combination of:
#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important.  Please see
# http://httpd.apache.org/docs-2.0/mod/core.html#options
# for more information.
#
    Options Indexes FollowSymLinks

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
    AllowOverride all

#
# Controls who can get stuff from this server.
#
#   onlineoffline tag - don't remove
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
</Directory>


change Allow from 127.0.0.1    to  Allow from All

Good Luck,
Tom


Traveling East in search of instruction, and West to propagate the knowledge I have had gained.

current projects: pokersource

My Blog | My Pastebin | PHP Validation class | Backtrack linux


#8 jana

jana
  • Members
  • PipPipPip
  • Advanced Member
  • 35 posts
  • LocationIndia

Posted 09 October 2006 - 11:47 AM

Thanx alot. its working fine
Jana




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users