Jump to content

Archived

This topic is now archived and is closed to further replies.

bjorno

PHP and GD

Recommended Posts

What is the best way to get GD working with PHP Version 5.1.4.

I have a default install of php on a Fedora server running with apache. When I a phpinfo.php GD isn't listed. Is there a config file i need to update or something else?

Share this post


Link to post
Share on other sites
I havnt got much experience with X servers but ive used GD on windows and found the site where i could download it and find documentation etc... in the FAQ (http://www.boutell.com/gd/faq.html) it says;

[quote]How do I install gd on Fedora Linux?
Try:

yum install gd-devel

Note: this might not install the latest, most-cutting edge version of gd, depending on the version of Fedora you are running and how current their gd packages are at the moment. [/quote]

I'm not sure if that means download the library first, if you do need to download it it is also on that site, if not then that should give you A version of GD tho as it says not always the latest one but methinks downloading it from that site will help :)

Share this post


Link to post
Share on other sites
Hi,

Dont know how to do it for your server but this is how 2 do it under windows. I think there is not much difference.

1. go to the following url [url=http://www.php.net/downloads.php]http://www.php.net/downloads.php[/url]

2. download "[color=red]PHP 5.2.0 zip package[/color]"

3. when downloaded open the zipfile and look for the file named "php_gd2.dll"

4. copy this file to your php folder something like ([color=red]C:\Program Files\PHP\extensions[/color]) or where ever your extension directory is.

5. locate your [color=red]php.ini[/color] file and open it.

6. search for the following line "[color=red];extension=php_gd2.dll[/color] " (line 641)
  and uncomment it(remove";")
  if this line reads "[color=red]extension=php_gd.dll[/color]" just rename it to "[color=red]extension=php_gd2.dll[/color]"

7. also change the [color=red]extension_dir = ".\"[/color] to extension_dir = [color=red]".\extensions"[/color]or what ever your extensions directory is (line 520)

Hope this helped.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.