Jump to content

Archived

This topic is now archived and is closed to further replies.

mikecicc

PHP.INI - Mail Function

Recommended Posts

k

I've been trying to utilize PHP's send mail function, problem is i need to change the PHP.ini file in order to swicthed around the default values of  SMTP_Port and SMTP Server, By default it's set to 'localhost' i need it to use my mail server; mail.whatever.com. ive been making the changes in the PHP.ini file under my c: on my web serv...don't see the php.ini file anywhere else, ive restarted my IIS numerous times, ive tried a bunch of things, any ideas? possibly an alternative route such as a PHP script which will chaneg these values fro me ? thanks
-mike

btw. when i do a phpinfo();
it thinks the config file (php.ini) is in c:\WINNt (which its not)...and it still dont recgnize the changes ive made to php.ini, although when i pull up the .ini file i see the changes...its as if i need to recompile php! .im lost please help :-[

Share this post


Link to post
Share on other sites
Run this script
[code]
<?php
phpinfo();
?>
[/code]

It will tell you the location of php.ini

Share this post


Link to post
Share on other sites
It was saying PHP.INI was in C:\WINNT on my local web server. which is wasn't. infact it was located : C:\PHP\php.ini     

but in any case, i changed the configuration of PHP from ASAPI module to a CGI, now PHP properly reads from php.ini located in my c:\PHP directory, which is great, now im experiecing another problem;

when i attempt to open; contact.php for example, or a majority of my .php documents, i get prompted to enter a login / password.

i login in as administrator and it takes me to the document just fine, everything works splended, but how do i turn of the CGI Authencation???????

im running an IIS server on windows 2000 server =[....although id like to go to apche , not everyone agrees here

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.