Jump to content

PHP.ini Issues

Recommended Posts

I'm having mega problems with my PHP configuration that:




PHP Help

Warrior Forum






Have not been able to help me resolve. It is a file upload script and the URL is valid on the server. I've been trying for weeks to resolve this issue and nobody seems to be able to help me locate the problem.


A more detailed description of the problem: Uploading files larger than 10MB nearly always fail but occasionally they get through. I believe the php.ini file to be setup correctly with the following settings:


file_uploads On

max_execution_time 1000

max_file_uploads 20

max_input_time 800

memory_limit 128M

post_max_size 70M

upload_max_filesize 50M

upload_tmp_dir C:\Temp\



C:\Temp\ is writable.


I have tried various scripts and all have the same outcome so I don't believe it to be a coding error.


I see the file upload to C:\Temp and when it fails the file remains so it's almost like it just doesn't want to move the file.


As I say, occasionally the file gets through and files less than 10MB get through fine so it is unlikely to be a permission issue. I also changed maxAllowedContentLength in IIS to 30000000 with no success. I then created an uploader in ASP which worked fine so this indicates its definitely a PHP issue.


I tried not even moving it away from C:\Windows\Temp and leaving it in there using the move_uploaded_file command and to my surprise it didn’t work.


I tried changing the php.ini to instead of put it in C:\Temp to put it in a writable D:\Temp folder and unusually when I force outputted an error by deliberately breaking the code I noticed that it was still trying to move it from C:\Windows\Temp and the tmp file was in fact in the C:\Windows\Temp folder. Could something be overriding my settings?


I did check via Plesk control panel to see if any custom settings were set but they weren’t, I checked in IIS PHP Manager also and nope, nothing out of the ordinary. I even tried switching PHP versions from 5.2 to 5.3 and even 5.4 but they all have the same issue.



I am totally lost with this one and nobody seems to be able to help me get the issue resolved.

Edited by scottlpool2003
Link to comment
Share on other sites

nothing you posted above shows the actual phpinfo() output you would have gotten. there would have been master and local value. at best you showed the command line phpinfo output and the CLI php generally doesn't uses the same php.ini that the web server invoked php would use.


if someone goes to the trouble of asking you a specific question to try and troubleshoot a problem, try your best to answer what was asked. sorry for the snarky reply, but i can see why you haven't gotten a solution after posting on all those forums you listed.

Link to comment
Share on other sites

  • 5 months later...
This thread is more than a year old. Please don't revive it unless you have something important to add.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.