Jump to content


Photo

PHP MYSQL Connection problem


  • Please log in to reply
2 replies to this topic

#1 Deep

Deep
  • Members
  • Pip
  • Newbie
  • 2 posts
  • LocationIndia

Posted 30 March 2003 - 12:05 PM

hi,
I m running my own server on WinXp SP1 with IIS and i have sucessfully installed PHP and MYSQL.

but the problem is with connection between PHP and MYSQL...I m trying to install a discussion forum (Invision Board) on my machine and there it asks for host name,db pass and all...i enetered all...and it shows foll error after submitting the data for next step :

Warning: mysql_connect() [function.mysql-connect]: Access denied for user: \'Deep@127.0.0.1\' (Using password: YES) in C:Inetpubwwwrootforumsm_install.php on line 395

and foll invision error :
The following errors must be rectified before continuing!

Please go back and try again! 

Could not create a mySQL connection, please check the SQL values entered.

other info :

MYSQL Part in php.ini

[MySQL]
; Allow or prevent persistent links.

mysql.allow_persistent = On


; Maximum number of persistent links.  -1 means no limit.

mysql.max_persistent = -1


; Maximum number of links (persistent + non-persistent).  -1 means no limit.

mysql.max_links = -1


; Default port number for mysql_connect().  If unset, mysql_connect() will use
; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the
; compile-time value defined MYSQL_PORT (in that order).  Win32 will only look
; at MYSQL_PORT.

mysql.default_port = 3306


; Default socket name for local MySQL connects.  If empty, uses the built-in
; MySQL defaults.

mysql.default_socket =


; Default host for mysql_connect() (doesn\'t apply in safe mode).

mysql.default_host = localhost


; Default user for mysql_connect() (doesn\'t apply in safe mode).

mysql.default_user = Deep


; Default password for mysql_connect() (doesn\'t apply in safe mode).
; Note that this is generally a *bad* idea to store passwords in this file.
; *Any* user with PHP access can run \'echo get_cfg_var("mysql.default_password")
; and reveal this password!  And of course, any users with read access to this
; file will be able to reveal the password as well.

mysql.default_password = 


; Maximum time (in secondes) for connect timeout. -1 means no limimt

mysql.connect_timeout = -1


; Trace mode. When trace_mode is active (=On), warnings for table/index scans and
; SQL-Erros will be displayed.

mysql.trace_mode = Off

I havent put anything for \"mysql.default_socket =\" (how to find the Deafult socket any idea ?) can it be the reason for that error ???

EDIT : REMOVED THE IMAGES

( in DataBase thing it doesnt show Create Database when u right click (is it only with me or its like that only) so i created using Command Prompt.)

can anyone help me with this ? why i m getting that error ? any idea ?
regards
Deep

P.S. PHP version is 4.3.1

Don't run behind the money, make money run behind you....- Deep


#2 shivabharat

shivabharat
  • Members
  • PipPipPip
  • Advanced Member
  • 371 posts
  • LocationChennai, India

Posted 31 March 2003 - 01:56 AM

in DataBase thing it doesnt show Create Database when u right click (is it only with me or its like that only) so i created using Command Prompt)

To create database u have to go to the mysql prompt and do it and I dont think its possible to do it from mysqladmin. There is a tool called \"SQLYOG\" which would be really handy because its GUI based.

Now comming to the error part

I guess its more of a code issue than config issue

Now the first thing I would recommend is flush or reset the password u set for the user Deep.

If u have mysql manual that would help u in great deal in resetting the password.


Now u dont have edit anything in the php.ini MYSQL takes up all default value. Try to remove the user \"deep\" u have entered in the php.ini.

Have a look @ this setting

[MySQL]
; Allow or prevent persistent links.
mysql.allow_persistent = On

; Maximum number of persistent links.  -1 means no limit.
mysql.max_persistent = -1

; Maximum number of links (persistent + non-persistent).  -1 means no limit.
mysql.max_links = -1

; Default port number for mysql_connect().  If unset, mysql_connect() will use
; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the
; compile-time value defined MYSQL_PORT (in that order).  Win32 will only look
; at MYSQL_PORT.
mysql.default_port =

; Default socket name for local MySQL connects.  If empty, uses the built-in
; MySQL defaults.
mysql.default_socket =

; Default host for mysql_connect() (doesn\'t apply in safe mode).
mysql.default_host =

; Default user for mysql_connect() (doesn\'t apply in safe mode).
mysql.default_user =

; Default password for mysql_connect() (doesn\'t apply in safe mode).
; Note that this is generally a *bad* idea to store passwords in this file.
; *Any* user with PHP access can run \'echo cfg_get_var(\\\"mysql.default_password\\\")
; and reveal this password!  And of course, any users with read access to this
; file will be able to reveal the password as well.
mysql.default_password =


All u other config looks fine

try to create another user and see if things work!!!

Just put on if u still have any issues!!!
Knowledge --- Reading Enriches Mind But Sharing Enhances It.[br][br]Note: Before you request help enusre that you have had a look at the tutorials @phpfreaks

#3 Deep

Deep
  • Members
  • Pip
  • Newbie
  • 2 posts
  • LocationIndia

Posted 31 March 2003 - 05:40 AM

oh thanks...i did all that and it worked actually there was something to do with the permissions also so i changed the permissions and now works fine...

thanks for the help
Deep

Don't run behind the money, make money run behind you....- Deep





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users