Jump to content

Getting an ORA-12518 error when using OCI8 after an upgrade from 10g to 12c

Go to solution Solved by MarkyO,

Recommended Posts

Hello everyone,

We recently upgraded from Oracle 10g to 12c and in doing so we broke any custom php programs that used oracle to connect.

I'm now getting this error:

Warning: oci_connect(): ORA-12518: TNS:listener could not hand off client connection

Of the things I've researched I've tried restarting the Listener services and setting the LogOn user as "Local System" in the service.

I've also tried adding



to the end of the listener.ora file.

Neither of those things worked.

Anyone have an idea? Should I x-post this to the oracle subreddit as well?

I have a .NET application that also connects to Oracle and that works fine, so I'm not sure why PHP doesn't connect.

Link to comment
Share on other sites

This thread is more than a year old. Are you sure you have something important to add to it?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.