Jump to content

ssh mysql without "|" separator?


Recommended Posts

When using SSH to do a short simple mySQL select query (e.g. "select animal_name from table limit 4"), the result looks like this:
| cat |
| dog |
| fish |
| bird |
Is there a way to disable the pipe "|" symbol so the result looks like this:
cat
dog
fish
bird

Thank you.

Link to post
Share on other sites

Use the -s option:

Quote

  -s, --silent        Be more silent. Print results with a tab as separator, each row on new line.

mysql -u $user -p -D $db -Nse "select blah" 

 

Link to post
Share on other sites
This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.