Jump to content

Fatal error: Uncaught mysqli_sql_exception: Table 'wordpress.wp_options' doesn't exist


Delayito
 Share

Recommended Posts

anyone can help me with this?

Fatal error: Uncaught mysqli_sql_exception: Table 'wordpress.wp_options' doesn't exist in C:\xampp\htdocs\wp-includes\wp-db.php:2056 Stack trace: #0 C:\xampp\htdocs\wp-includes\wp-db.php(2056): mysqli_query(Object(mysqli), 'SELECT option_n...') #1 C:\xampp\htdocs\wp-includes\wp-db.php(1945): wpdb->_do_query('SELECT option_n...') #2 C:\xampp\htdocs\wp-includes\wp-db.php(2695): wpdb->query('SELECT option_n...') #3 C:\xampp\htdocs\wp-includes\option.php(284): wpdb->get_results('SELECT option_n...') #4 C:\xampp\htdocs\wp-includes\functions.php(1730): wp_load_alloptions() #5 C:\xampp\htdocs\wp-includes\load.php(752): is_blog_installed() #6 C:\xampp\htdocs\wp-settings.php(159): wp_not_installed() #7 C:\xampp\htdocs\wp-config.php(96): require_once('C:\\xampp\\htdocs...') #8 C:\xampp\htdocs\wp-load.php(50): require_once('C:\\xampp\\htdocs...') #9 C:\xampp\htdocs\wp-blog-header.php(13): require_once('C:\\xampp\\htdocs...') #10 C:\xampp\htdocs\index.php(17): require('C:\\xampp\\htdocs...') #11 {main} thrown in C:\xampp\htdocs\wp-includes\wp-db.php on line 2056

Link to comment
Share on other sites

I'm not sure what anyone can do to help beyond what the error is telling you.  It is looking in a database named 'wordpress' for the table 'wp_options' but that table doesn't exist.  Did your wordpress install complete successfully?  Do you have phpMyAdmin or some other way to look at your mysql server, to check the existence of databases and tables?

Link to comment
Share on other sites

Same issue for me on IIS - Fatal error: Uncaught mysqli_sql_exception: Table 'testsite.wp_options' doesn't exist in C:\inetpub\wwwroot\testsite\wp-includes\wp-db.php:2056 Stack trace: #0 C:\inetpub\wwwroot\testsite\wp-includes\wp-db.php(2056): mysqli_query() #1 C:\inetpub\wwwroot\testsite\wp-includes\wp-db.php(1945): wpdb->_do_query() #2 C:\inetpub\wwwroot\testsite\wp-includes\wp-db.php(2695): wpdb->query() #3 C:\inetpub\wwwroot\testsite\wp-includes\option.php(284): wpdb->get_results() #4 C:\inetpub\wwwroot\testsite\wp-includes\functions.php(1730): wp_load_alloptions() #5 C:\inetpub\wwwroot\testsite\wp-includes\load.php(752): is_blog_installed() #6 C:\inetpub\wwwroot\testsite\wp-settings.php(159): wp_not_installed() #7 C:\inetpub\wwwroot\testsite\wp-config.php(99): require_once('...') #8 C:\inetpub\wwwroot\testsite\wp-load.php(50): require_once('...') #9 C:\inetpub\wwwroot\testsite\wp-admin\admin.php(34): require_once('...') #10 C:\inetpub\wwwroot\testsite\wp-admin\index.php(10): require_once('...') #11 {main} thrown in C:\inetpub\wwwroot\testsite\wp-includes\wp-db.php on line 2056

Created DB manually, modified the wpconfig-php manually but no dice on setup... 

Link to comment
Share on other sites

I have the same answer for you.  The table doesn't exist.  It needs to for wordpress to work

In both cases, it sounds like the database was not prepared or wordpress was not configured with the needed credentials for the install to create the wordpress tables.

Wordpress has some documentation that might help you

In general you need to verify

  • The user/password combination works
  • A database for wordpress was created
  • You have configured these facts during your wordpress install
  • When the wordpress install completes, verify the database has the wordpress tables created.
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.