Jump to content

Archived

This topic is now archived and is closed to further replies.

sid2006

php.ini is not recognized

Recommended Posts

I have been trying to get the php.ini file to be recognized by phpinfo and have had no luck.

PHP Version 4.3.4
Solaris 2.8
GCC compiler 3.3.2

Initially, when I ran configure I used these options:

./configure
--with-mysql
--with-apxs2=/usr/local/apache2.0.54/bin/apxs
--with-gd
--with-png-dir=/usr/local/lib
--with-jpeg-dir=/usr/local/lib
--with-zlib-dir=/usr/local/lib

The Config file piece of the ouput of the phpinfo page is:

Configuration File (php.ini) Path /usr/local/lib/


CLI actually shows the path and file name:

# ./original.php -i|more
phpinfo()
PHP Version => 4.3.4

System => SunOS umgwww4 5.8 Generic_108528-29 sun4u
Build Date => Feb 28 2006 19:20:00
Configure Command => './configure' '--with-mysql' '--with-apxs2=/usr/local/apache2.0.54/bin/apxs' '--with-gd' '--with-png-dir=/usr/
local/lib' '--with-jpeg-dir=/usr/local/lib' '--with-zlib-dir=/usr/local/lib' '
Server API => Command Line Interface
Virtual Directory Support => disabled
Configuration File (php.ini) Path => /usr/local/lib/php.ini
PHP API => 20020918
PHP Extension => 20020429
Zend Extension => 20021010
Debug Build => no
Thread Safety => disabled
Registered PHP Streams => php, http, ftp, compress.zlib

I have another system that is identical and works fine. I tried copying over the php CLI and entire /usr/local/lib/php directories and the libphp4.so apache module and then restarted. Still didn;t work

I then tried a compile with:

--with-config-file-path=/usr/local/lib/php.ini (even though you are only suppose to use the path)

Still didn't work.

Any ideas?

thanks,
sid




Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.