Jump to content

Archived

This topic is now archived and is closed to further replies.

2muchspam

Authentication problems -HELP-

Recommended Posts

I want to keep a directory from public view. (/foo)

I\'ve enabled digest auth and it works fine for /foo.

The web-based program (php/mysql/gd) works just fine without any auth, but when auth is enabled, it doesn\'t. I can log in and see the index page, but none of the links work. I messed with it for a while and got it to let me follow links, but the app won\'t make images anymore (using gd) unless I remove the auth. Here is an excerpt from my httpd.conf:

<Directory "x:/apache/apache2/htdocs/foo">

   AllowOverride None

   AuthType Digest

   AuthName securearea

   AuthDigestFile x:/xxxxxxx/xxxxx/.passwdfile

   AuthGroupFile /dev/null

   Require user appuser

#    Options  -indexes +Includes +ExecCGI

#Order allow,deny

#Allow from all

</Directory>

 

ANY HELP GREATLY APPRICIATED!!!!!

Thanks!

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.