Jump to content

Archived

This topic is now archived and is closed to further replies.

gbb123

Apache2, mod_suexec, cgi!

Recommended Posts

I am having problems getting mod_suexec to work properly I put user user_name group group_name in the vhost containers but I always get an error when starting apache2 saying that the module is not configured properly I look in server-info and get this for mod_suexec.c:

 

 

Module Name: mod_suexec.c

Content handlers: none

Configuration Phase Participation: Create Directory Config, Create Server Config

Request Phase Participation: none

Module Directives:

SuexecUserGroup - User and group for spawned processes

Current Configuration:

SuexecUserGroup apache apache

 

I am running Apache-AdvancedExtranetServer/2.0.44 (Mandrake Linux/11mdk) mod_perl/1.99_08 Perl/v5.8.0 auth_mysql/1.11 mod_ssl/2.0.44 OpenSSL/0.9.7a PHP/4.3.1 Server at ag-webhosting.com Port 80

 

Ive checked all the suexec documentation,http://httpd.apache.org/docs-2.0/suexec.html the alias for extramodules is correct, and here is the /etc/httpd/conf.d/69_mod_suexec.conf file info:

 

<IfDefine HAVE_SUEXEC>

<IfModule !mod_suexec.c>

LoadModule suexec_module extramodules/mod_suexec.so

</IfModule>

</IfDefine>

 

<IfModule mod_suexec.c>

SuexecUserGroup apache apache

 

</IfModule>

 

Do I have to specify somewhere globally HAVE_SUEXEC or is there something else that I have to do to turn it on? I read that when you compile it you must specify to turn it on, but I added this through an rpm package in mandrake. It was something like apache2-modules, after I installed apache2.

 

please if anyone knows how to work with suexec and cgi help me out because I need this to work properly on my server for security reasons, thanx in advance to anyone who can help me.

 

Garrett

 

:?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.