Jump to content


Photo

Connecting to DB... halting


  • Please log in to reply
No replies to this topic

#1 bcreque

bcreque
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 10 April 2006 - 12:06 AM

Hey,

Hopefully someone can help me out.

I am having a problem that occurs only with my hosting company. On my development server, I don't have the issue.

I have a class (class1) that is included by my main UI. Class1 has a class included (class2). Class2 is responsible for db connections, queries, etc. I ran without any problems for a couple days. And then, suddenly none of my clients could log in. All that is being shown now is a blank screen. I figured out that the problem is that for whatever reason, my script is halting/hanging on my mysql_connect call. Anything before this line, works fine, anything after it, doesn't get touched. There is NO error being printed out (even when I supply a "or die..." clause).

I've really struggled with this problem and am having to host it all on my dev server right now which is very annoying and I can't really get anything done until I get it back up and running. Hopefully someone can help me out.

Do you think this could be some sort of hosting issue? I can connect with a very simple test script that all it does is call mysql_connect to establish a connection, but it will always hang on the call which is nested in my classes.

Any ideas what may be causing this?

I'm sure you probably need more information to help me out. If you do, let me know.

Thanks,
Bryant





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users