Jump to content


Photo

sending email


  • Please log in to reply
1 reply to this topic

#1 manamino

manamino
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 12 April 2006 - 04:35 PM

I faced the following error while trying to send an email using php:
my php file is as follows:

<?php
$to=$_POST["email"];
$password=$_POST["password"];
$login=$_POST["login"];
$msg="Your login and password are as follows:
login Id:".$login."
Password:" .$password;
$from = "From: xxx@xxx.xxx<br>";
if( mail ( $to, "login information", $msg, $from ))
{
echo "Your password was successfully sent to you<br>";

}
else
echo "Could not sent you an email with there password!";

?>


the error is as follows:

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\Program Files\Apache Group\Apache2\htdocs\xml forum project\password.php on line 9

As I find I should have a local mail server on my laptop to do that:
I downloaded a mail server called: Argosoft mail server and it is installed on my computer
what should I do to make it work
what changes should I do to my php.ini file
please help!


#2 jworisek

jworisek
  • Members
  • PipPipPip
  • Advanced Member
  • 112 posts

Posted 12 April 2006 - 04:56 PM

fixing the msg variable would help....

you were ending it before $password was put in it.

$msg="Your login and password are as follows:
login Id:".$login."
Password:" .$password. "";

also, use newline ( \n ) instead of <br> in $from

for the php.ini, verify that you have a username and password set up for php to connect to you SMTP server.

Also try setting

SMTP = www.yourdomainname.com

instead of localhost




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users