Jump to content


Photo

JPEG with GD


  • Please log in to reply
3 replies to this topic

#1 jsvoyager

jsvoyager
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 15 April 2006 - 03:27 AM

I've just installed with the following config options:

./configure --with-zlib-dir=/usr/include --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-sqlite --with-xml --enable-calendar --with-curl --enable-ftp --enable-magic-quotes --with-config-file=/etc --with-gd --with-jpeg --with-ttf --with-fretype --with-t1li --with-pear
Please note the --with-jpeg option.

However, after looking at phpinfo() the gd section shows no JPEG. I've tried configuration with --with-jpeg=/usr/local/bin and --with-jpeg=[compilation folder] and none of these option alow JPEG to work with GD.

Anyone know what's wrong?

Thanks

#2 Sakrag

Sakrag
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 27 April 2006 - 11:38 PM

[!--quoteo(post=364979:date=Apr 14 2006, 10:27 PM:name=jsvoyager)--][div class=\'quotetop\']QUOTE(jsvoyager @ Apr 14 2006, 10:27 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
I've just installed with the following config options:

./configure --with-zlib-dir=/usr/include --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-sqlite --with-xml --enable-calendar --with-curl --enable-ftp --enable-magic-quotes --with-config-file=/etc --with-gd --with-jpeg --with-ttf --with-fretype --with-t1li --with-pear
Please note the --with-jpeg option.

However, after looking at phpinfo() the gd section shows no JPEG. I've tried configuration with --with-jpeg=/usr/local/bin and --with-jpeg=[compilation folder] and none of these option alow JPEG to work with GD.

Anyone know what's wrong?

Thanks
[/quote]

[!--quoteo--][div class=\'quotetop\']QUOTE[/div][div class=\'quotemain\'][!--quotec--]
Never mind after a bit of logn research i figure dit out. Appraently there is a bug in the php5 config script that caches config wrong. This causes gd to be screwed up if you already have compiled one before with out gd support. To resolve I downlaoded fresh sources and recompiled fresh.

Sorry about this waste of a thread, it seems I always do hours of searching, then post on a forum and two minutes later find the answer.[/quote]

[a href=\"http://www.phpfreaks.com/forums/index.php?s=&showtopic=92251&view=findpost&p=369391\" target=\"_blank\"]http://www.phpfreaks.com/forums/index.php?...ndpost&p=369391[/a]


#3 jsvoyager

jsvoyager
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 06 May 2006 - 09:16 PM

Thanks for the tip. Works perfectly now.

#4 aluminumpork

aluminumpork
  • New Members
  • Pip
  • Newbie
  • 6 posts

Posted 09 July 2006 - 06:43 PM

Thanks for the tip also. I was stumped.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users