Jump to content


Photo

*SOLVED* Help!!! php code


  • Please log in to reply
4 replies to this topic

#1 Michael2k5

Michael2k5
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 16 April 2006 - 07:49 PM

this is it im about to go crazy.. if some one doesn't help me im going to jump from the bridge

<?php
if (!isset($snx)) $snx="";
if ($snx == "") $snx = "home";
if (!file_exists($snx.".php")) $snx = "home";
include($snx.".php");
?>

thats the code... it used to work but now it doesn't can someone pleeasee help me with this

#2 Barand

Barand
  • Moderators
  • Sen . ( ile || sei )
  • 18,020 posts

Posted 16 April 2006 - 08:11 PM

First question, what changed since it last worked?

Does the file you are trying to include exist?

If it does, is it in a directory that is defined in your include_path?
If you are still using mysql_ functions, STOP! Use mysqli_ or PDO. The longer you leave it the more you will have to rewrite.

Donations gratefully received






moon.png

|baaGrid| easy data tables - and more
|baaChart| easy line, column and pie charts

#3 Michael2k5

Michael2k5
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 16 April 2006 - 08:21 PM

nvm lol i fixed it but now i hav a new problem...

i got this login script right from jpmaster77

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at E:\xampp\xampplite\htdocs\Skynet\app\main.php:7) in E:\xampp\xampplite\htdocs\Skynet\app\include\session.php on line 46

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at E:\xampp\xampplite\htdocs\Skynet\app\main.php:7) in E:\xampp\xampplite\htdocs\Skynet\app\include\session.php on line 46

this is the error i get

but the weird thing is that the code works perfectly but it gives me that error

#4 ypirc

ypirc
  • Members
  • PipPipPip
  • Advanced Member
  • 54 posts

Posted 16 April 2006 - 08:26 PM

[a href=\"http://www.phpfreaks.com/forums/index.php?showtopic=37442\" target=\"_blank\"]http://www.phpfreaks.com/forums/index.php?showtopic=37442[/a]

#5 Michael2k5

Michael2k5
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 17 April 2006 - 04:15 AM

thanx.. i solved it :D




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users