Jump to content


Photo

Can't get connection


  • Please log in to reply
1 reply to this topic

#1 Endrew

Endrew
  • Members
  • PipPip
  • Member
  • 15 posts

Posted 25 April 2006 - 10:22 PM

MYSQL 5.0 , IIS 5.1, Windows XP Professional Edition

Whenever i call mysql_connect function I got this error message.
[Quote]
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ODBC'@'localhost' (using password: NO) in c:\Inetpub\wwwroot\info\~phpdesigner_output_tmp.php on line 2
[Quote]

When i change login password, using MYSQL SERVER INSTANCE CONFIG WIZARD, I've got this error message during setting up process. I turned off firewall as the msg said. But it doesn't work. Is there a way to solve this problem?
[Quote]
Error Nr.1045
Access denied for user 'root'@'localhost'(using password:NO)
If a personal firewall is running on your machine, please make sure you have opened the TCP port 3306 for connections. Otherwise no client application can connect to the server. After you have opened the port please press [Retry] to apply the security settings. If you are re-installing after you just uninstalled the MySQL server please note that the data directory was not removed automatically. Therefore the old password from your last installation is still needed to connect to ther server. In this case please select skip now and re-run the Configuration Wizard from the start menu.
[Quote]



#2 PWD

PWD
  • Members
  • PipPip
  • Member
  • 19 posts

Posted 26 April 2006 - 03:57 AM

Windows Firewall probanly has port 3306 blocked. Do you have SP2 installed? If so, go to Start => Settings => Control Panel => Windows Firewall. Select the option, "Off" to completely disable the firewall and then try to reconnect to MySQL. If you can connect, you'll have to create an exception in Windows Firewall to run both...
[!--fonto:Geneva--][span style="font-family:Geneva"][!--/fonto--]My Gratitude---[!--fontc--][/span][!--/fontc--]
(My gratitude in advance for helping me learn; so I may one day give as freely as you have here today)
----------
[!--sizeo:5--][span style="font-size:18pt;line-height:100%"][!--/sizeo--][!--fonto:Optima--][span style="font-family:Optima"][!--/fonto--][!--coloro:red--][span style="color:red"][!--/coloro--]PWD[!--sizec--][/span][!--/sizec--][!--colorc--][/span][!--/colorc--][!--fontc--][/span][!--/fontc--]




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users