Jump to content


This topic is now archived and is closed to further replies.


Issues with GD

Recommended Posts

I have never had a problem before compiling php4, now however im trying to compile php5 and i am having trouble with gd support. I am using a gentoo system and even though I have portage installed I am compiling all the sources myself. Anyway no matter how i compile php gd doesnt appear to work. I would really like GD2 working, but it doesnt work at all, and if I compile --with-gd it works however there is no support for jpeg, even if I use --with-jpeg-dir=/usr/lib. I can't figure this out and it is important as I have a few scripts that require jpeg gd support.

I am using the following configure command:
./configure --with-apxs2=/opt/apache2/bin/apxs --enable-ftp --enable-inline-optimization --enable-magic-quotes --enable-mbstring --enable-mm=shared --enable-track-vars --enable-trans-sid --enable-wddx=shared --enable-xml --with-dom --with-gd2 --with-gettext --with-mysql --with-regex=system --with-xml --with-zlib-dir=/usr/lib --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib

php_info() shows no gd2 support and there is no shared gd2.so object created after i run make. When i use --with-gd instead, php_info() shows that gd is supported with png and gif but not jpeg. My scripts also give a function not found error when i try and create a jpeg image.

Any ideas?

Share this post

Link to post
Share on other sites
Never mind after a bit of logn research i figure dit out. Appraently there is a bug in the php5 config script that caches config wrong. This causes gd to be screwed up if you already have compiled one before with out gd support. To resolve I downlaoded fresh sources and recompiled fresh.

Sorry about this waste of a thread, it seems I always do hours of searching, then post on a forum and two minutes later find the answer.

Share this post

Link to post
Share on other sites


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.