Jump to content

Archived

This topic is now archived and is closed to further replies.

walkero

Problem with the URL variables...

Recommended Posts

I have a problem with a pc Win Xp pro installation of apache and php...

I installed it as the manual says, it runs fine with no error

on error.log. I also installed the latest version of MySQL as

a service.

Everything work just fine. The phpMyAdmin 2.5.3-rc1 works great

with no problem...

 

In there I put a folder with a page that I made. I use the same

code on an other computer with an older version of apache and

works just fine. At the new computer with the latest version

there is a problem. It doesn\'t use the extra parameters on a URL.

What I mean is that a URL like

http://morpheus:82/guestbook.php?todo=add

does not return a value of the variable todo. So I can\'t use the

<?php

echo $todo;

?>

to get back that value. It returns nothing.

 

But the phpMyAdmin 2.5.3-rc1 works great without having the problem

that my page have.

 

Does anyone know what\'s wrong?

Share this post


Link to post
Share on other sites

try echo $_GET[$todo]; ... this is affected by register_globals in your php.ini

Share this post


Link to post
Share on other sites

you mean that the variable \"todo\" is something that we shouldn\'t use...????

I fixed it by changing the register_globals....

 

Also there is one more problem. The server doesn\'t send the cookies...do you have any clue about that?

 

thanks for your help

Share this post


Link to post
Share on other sites

Greetings,

One place to look in regards to the cookie handling,

is in your php.ini file. There is a section specifically

regarding wheather or not, and how PHP will handle

cookies. This does not mean that your script may

not be the reason. It is simply one reason you may be

having trouble.

 

Best wishes,

Chris

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.