Jump to content

Archived

This topic is now archived and is closed to further replies.

colincannon

phpsessid killing me

Recommended Posts

I noticed that google was indexing my site with phpsessid in the url. Also I needed to get rid of it because it messes up my site sometimes when I use header(location:???), therefore I want to permantly get rid of phpsessid.

So I put these lines in my .htaccess file to do the job.

php_value session.use_only_cookies 1
php_value session.use_trans_sid 0

They work getting rid of the phpsessid variable but it also caused one problem that I can't live with. The problem is that the first time you try to log into my site the session does not register, but once you try it a second time it works fine.

Any ideas what would cause somehting like that?

Share this post


Link to post
Share on other sites
ttt

Just to clarify I have session_start() as the first line in all of my php pages

any ideas would be greatly appreciated

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.