Jump to content

Help with PHP and IB forums


fhripper
 Share

Recommended Posts

Hi Guys,

PLease bare with me as im new to this and still learning

but heres my so called forums link

[a href=\"http://www.clublan.info/forums/\" target=\"_blank\"]http://www.clublan.info/forums/[/a]

as you find the following issue

Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in /var/virtual/web/w0653/html/forums/sources/Drivers/mySQL.php on line 64

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /var/virtual/web/w0653/html/forums/sources/Drivers/mySQL.php on line 67
ERROR: Cannot find database
Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /var/virtual/web/w0653/html/forums/sources/Drivers/mySQL.php on line 100

Now this is a problem as my host just changed servers to the optus data center my host is smarty.

I have tryed to contact but seems they a re very busy and wont get back in touch with me..

Anyone have any ideas how i can fix this issue i dont wanna loose my forums as there were a few registed member sna a few threads.

anyone help pleasee...

Cheers

Tim
Link to comment
Share on other sites

All the errors you are getting are caused by the first error message. Once the first error message is solved all the other errors will disappear.


To solve this error you will need set the password for your mysql username with the OLD_PASSWORD function.

You can do this via the command line/shell if you have access to this. If you dont then ask you host to set your mysql password with the OLD_PASSWORD function.

[a href=\"http://dev.mysql.com/doc/refman/5.0/en/old-client.html\" target=\"_blank\"]Click here[/a] for more information on how to set your mysql passord with the OLD_PASSWORD function.
Link to comment
Share on other sites

[!--quoteo(post=375177:date=May 19 2006, 08:38 PM:name=wildteen88)--][div class=\'quotetop\']QUOTE(wildteen88 @ May 19 2006, 08:38 PM) [snapback]375177[/snapback][/div][div class=\'quotemain\'][!--quotec--]
All the errors you are getting are caused by the first error message. Once the first error message is solved all the other errors will disappear.
To solve this error you will need set the password for your mysql username with the OLD_PASSWORD function.

You can do this via the command line/shell if you have access to this. If you dont then ask you host to set your mysql password with the OLD_PASSWORD function.

[a href=\"http://dev.mysql.com/doc/refman/5.0/en/old-client.html\" target=\"_blank\"]Click here[/a] for more information on how to set your mysql passord with the OLD_PASSWORD function.
[/quote]


Im sorry but i have no idea how to do this ...

I cannot contact my host as there useless and this is driving me crazy ..

im with smarty host

Could you explained it a little easyer on what i have to doo
Link to comment
Share on other sites

Ok ifound a SQL qury box in PHP my admin for the server

this is the responce i got

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql> SET PASSWORD FOR
-> 'w0653@localhost' = OLD_PASSWORD

update

i was able to run

SET PASSWORD FOR 'some_user'@'some_host' = OLD_PASSWORD('mypass');

and it said it was fine

but still issues with site...

Link to comment
Share on other sites

You should use this query:
[code]SET PASSWORD FOR 'some_user'@'some_host' = OLD_PASSWORD('mypass');[/code]
Make sure that you change where it says [b]some_user[/b] is changed to your actuall mysql username and [b]some_host[/b] is changed to [b]localhost[/b]. Then type in your actual password where it says [b]mypass[/b]

That should sort out your problem. If it doesn't then there isn't anything else you can do AFAIK. In order for this problem to be sorted out you will need to get in contact with your host to sort the problem out.

What I find strange is that you can use phpMyAdmin but you cant use IPB!
Link to comment
Share on other sites

[!--quoteo(post=375237:date=May 20 2006, 12:47 AM:name=wildteen88)--][div class=\'quotetop\']QUOTE(wildteen88 @ May 20 2006, 12:47 AM) [snapback]375237[/snapback][/div][div class=\'quotemain\'][!--quotec--]
You should use this query:
[code]SET PASSWORD FOR 'some_user'@'some_host' = OLD_PASSWORD('mypass');[/code]
Make sure that you change where it says [b]some_user[/b] is changed to your actuall mysql username and [b]some_host[/b] is changed to [b]localhost[/b]. Then type in your actual password where it says [b]mypass[/b]

That should sort out your problem. If it doesn't then there isn't anything else you can do AFAIK. In order for this problem to be sorted out you will need to get in contact with your host to sort the problem out.

What I find strange is that you can use phpMyAdmin but you cant use IPB!
[/quote]

I have done this and it tlls me to reload privages.

do i have to login to complete this.. (login into mysql)
is there a command i need to login with
Link to comment
Share on other sites

This thread is more than a year old. Are you sure you have something important to add to it?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.