Jump to content

Archived

This topic is now archived and is closed to further replies.

socal_0351

php returns japenesse characters

Recommended Posts

hi,

i have a website hosted by earthlink. im able to use php 5+ and 4+. my problem is that i have a form that posts to my php script, lets call it "proccess.php5" (earthlink requires the ext of php5 or php4). now the problem is that all my results(at least i think they are) are returned in what appears to be japenesse characters. i've never seen this before. but if i directly access "process.php5", i can view it in english. ummm, yah, i have no idea whats going on. does anyone know anything about this. this is something i would like to fix, obviously.
any suggestions would be appreciated.

thank you

Share this post


Link to post
Share on other sites
Sounds like a problem with the character set definition in your 'results' page. View the source (html) in a browser to check that.

Share this post


Link to post
Share on other sites
[!--quoteo(post=382474:date=Jun 11 2006, 07:33 AM:name=AndyB)--][div class=\'quotetop\']QUOTE(AndyB @ Jun 11 2006, 07:33 AM) [snapback]382474[/snapback][/div][div class=\'quotemain\'][!--quotec--]
Sounds like a problem with the character set definition in your 'results' page. View the source (html) in a browser to check that.
[/quote]


thanks for responding. im looking at it, but i dont see anything unusal. what should i specifically be looking for?

Share this post


Link to post
Share on other sites
It may be an encoding problem, try to use the header() function or meta tags and set the correct encoding:

[a href=\"http://www.php.net/header\" target=\"_blank\"]http://www.php.net/header[/a]

[code]<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">[/code]

Share this post


Link to post
Share on other sites
[!--quoteo(post=382731:date=Jun 11 2006, 11:09 PM:name=poirot)--][div class=\'quotetop\']QUOTE(poirot @ Jun 11 2006, 11:09 PM) [snapback]382731[/snapback][/div][div class=\'quotemain\'][!--quotec--]
It may be an encoding problem, try to use the header() function or meta tags and set the correct encoding:

[a href=\"http://www.php.net/header\" target=\"_blank\"]http://www.php.net/header[/a]

[code]<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">[/code]
[/quote]


poirot

that did the trick thanks. its makes life a lot nicer now. i appreciate it

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.