Jump to content

Archived

This topic is now archived and is closed to further replies.

ivytony

How to install XDebug for PHP5 on windows?

Recommended Posts

I am using Apache + PHP 5.2.8 on my laptop installed with Windows Vista 32 and it works just fine. I have been trying to install XDebug since last night, but haven't got any luck getting it to work.

 

Basically, I downloaded the .dll binary file (5.3 VC9) from http://www.xdebug.org/download.php, and put it in the PHP extension directory (C:\php\ext), then changed the php.ini to below:

 

uncommented this line:

extension=php_xdebug.dll

 

added this block at the end of the file:

 

[XDebug]

;; Only Zend OR (!) XDebug

zend_extension_ts="C:\php\ext\php_xdebug-2.0.4-5.3.0-vc9.dll"

xdebug.remote_enable=true

xdebug.remote_host=localhost

xdebug.remote_port=10000

xdebug.remote_handler=dbgp

xdebug.profiler_enable=1

xdebug.profiler_output_dir="C:\php\xdebug\tmp"

 

I restarted my apache, but I still couldn't find the XDebug section in my phpinfo.php output. I wonder what else I need to do?

 

Thanks in advance!

 

 

Share this post


Link to post
Share on other sites

You dont need to add php_xdebug.dll to the extension= list you only need to add the block of configuration that you added. Make sure zend_extension_ts= points to the dll file you just downloaded

 

After making changes to the php.ini restart your http server.

 

Also as you're using php5.2.x you should of downloaded 5.2 VC6 not 5.3 VC9

Share this post


Link to post
Share on other sites

You dont need to add php_xdebug.dll to the extension= list you only need to add the block of configuration that you added. Make sure zend_extension_ts= points to the dll file you just downloaded

 

After making changes to the php.ini restart your http server.

 

Also as you're using php5.2.x you should of downloaded 5.2 VC6 not 5.3 VC9

 

all right, I just did what you suggested here, but I still cannot see the 'xdebug' shown in my phpinfo.php output. any ideas? :( thanks

Share this post


Link to post
Share on other sites

Make sure you edit correct php.ini file.

Share this post


Link to post
Share on other sites

tried everything, but still xdebug doesn't show up in phpinfo(). I am pretty sure that I am editing the right php.ini file.

Share this post


Link to post
Share on other sites

run phpinfo() and post what the Loaded Configuration File line reads.

Share this post


Link to post
Share on other sites

Look in Apache's error log.  If it says something about unable to find the DLL, try stating the path differently (drive letter and / instead of \ or something).

 

If it doesn't say any error or anything, then you are editting the wrong php.ini.

Share this post


Link to post
Share on other sites

phpinfo() shows:

 

1. Loaded Configuration File C:\php\php.ini

 

2. Loaded Modules:

 

core mod_win32 mpm_winnt http_core mod_so mod_actions mod_alias mod_asis mod_auth_basic mod_authn_default mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_dir mod_env mod_include mod_isapi mod_log_config mod_mime mod_negotiation mod_rewrite mod_setenvif mod_php5

 

 

 

Here's the error message in apache error logs:

 

Xdebug requires Zend Engine API version 220070929.

The Zend Engine API version 220060519 which is installed, is outdated.

 

 

I wonder what this means?

Share this post


Link to post
Share on other sites

Strange... how can you get outdated API with PHP 5.2.8???

Share this post


Link to post
Share on other sites

Strange... how can you get outdated API with PHP 5.2.8???

 

exactly! PHP Version 5.2.8

 

Should I install the latest version of Zend Engine?

Share this post


Link to post
Share on other sites

What are your versions of Apache. Xdebug is compatible with certain API versions. I have Apache2.2.11 and PHP5.2.8

 

xdebug (v5.2VC9) works for me

Share this post


Link to post
Share on other sites

I've Apache 2.2.10 and PHP 5.2.6. Working with XDebug 5.2VC6

Share this post


Link to post
Share on other sites

Hello, I'm totaly newbie in PHP and it is my first post so don't be to mean:D

 

Today i had similar problem.

Problem was in bad file path.

 

I'm using WAMP pack so probably this is diffrent situation, but if you are  using PHP as Apache module,  your PHP.INI have to be somewhere here: "/php5/apache/php.ini "

 

in XAMPP:"apache/bin/php.ini"

 

in WAMP: "wamp/bin/apache/Apache2.2.11/bin/php.ini"

 

In first moment i tried to edit: "wamp/bin/php/php5.2.8/php.ini". 

That was my mistake. This .ini was first one I found. :'(

 

 

I have php 5.2.8

xdebug - php_xdebug-2.0.4-5.2.8.dll

everything is ok now.

 

Share this post


Link to post
Share on other sites

WampServer has a shortcut to php.ini in its tray menu.

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.