Jump to content


Photo

connecting to server


  • Please log in to reply
4 replies to this topic

#1 mysty

mysty
  • Members
  • PipPipPip
  • Advanced Member
  • 83 posts

Posted 16 August 2006 - 11:00 PM

I am able to use localhost to create my MySql databases and add data etc.  However, when I try to use the command prompt to connect to the server version (my ISP host), I don't know how to do that.  I tried SQLyog and was able to connect to the server, but can't do it using the cmd prompt.  When in SQLyog for host, I typed "mysql.domainname.com" (without the quotes and using my real domain name).  When I try that in mysql it does not work.  For example, "mysql -h mysql.domainname.com, -u username, -p password;".  For the host name in the example I have tried "http://my.... ",  "www.my...", http://www.my...", plus a few others, but to no avail.  Any ideas?  Do I need to contact my ISP to find out what is correct?

Forgot to add that I can use PHPmyadmin and get to localhost, but not the server.  How do I do that?

#2 JadedLucidity

JadedLucidity
  • Members
  • PipPip
  • Member
  • 11 posts

Posted 17 August 2006 - 01:12 AM

You are trying to connect to your sql service on your local machine that your setting at?
"start" menu
go to "run"

type in box
mysql --user=your_user --password=yourpassword dbyouwanttoconnectto

click ok.

this will bring up mysql command line


#3 mysty

mysty
  • Members
  • PipPipPip
  • Advanced Member
  • 83 posts

Posted 17 August 2006 - 10:03 AM

I can connect to the database from localhost.  My problem is trying to connect using my local ISP host server when using mysql from the command prompt.

#4 JadedLucidity

JadedLucidity
  • Members
  • PipPip
  • Member
  • 11 posts

Posted 17 August 2006 - 08:36 PM

Call your isp, I am no help there. sorry  :-[

#5 fenway

fenway
  • Staff Alumni
  • MySQL Si-Fu / PHP Resident Alien
  • 16,199 posts
  • LocationToronto, ON

Posted 18 August 2006 - 04:05 PM

Sounds like a firewall / IP restriction issue -- most servers are set up to permit local connections only.
Seriously... if people don't start reading this before posting, I'm going to consider not answering at all.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users