Jump to content


Photo

GD on localhost


  • Please log in to reply
7 replies to this topic

#1 ahmed17

ahmed17
  • Members
  • PipPipPip
  • Advanced Member
  • 59 posts

Posted 09 September 2006 - 09:57 PM

what is the way to make GD libary work on localhost with no problem ..?

#2 onlyican

onlyican
  • Members
  • PipPipPip
  • Advanced Member
  • 921 posts
  • LocationHants - UK

Posted 09 September 2006 - 10:10 PM

Download the GB lib dll and set it up in the php.ini file
Tell me the problem, I will try tell you the solution

#3 AndyB

AndyB
  • Staff Alumni
  • Advanced Member
  • 5,465 posts
  • LocationToronto

Posted 09 September 2006 - 10:30 PM

@ahmed17

What server operating system do you have. What version of php? What version of the GD library?  Is this on a PC or a Mac?  That may be crucial information people need to resolve this for you.  Don't make them guess.
Legend has it that reading the manual never killed anyone.
My site

#4 ahmed17

ahmed17
  • Members
  • PipPipPip
  • Advanced Member
  • 59 posts

Posted 09 September 2006 - 10:38 PM

1)GD Version  1.6.2 or higher 
2)os winxp sp2
3)AppServ on my local machine
4)gd work with me when i upload the page to live server (free) support php but not work on local server
so it  distrubiute me when i want test any script  ???

#5 ahmed17

ahmed17
  • Members
  • PipPipPip
  • Advanced Member
  • 59 posts

Posted 10 September 2006 - 10:53 PM

wat i do ?

#6 Barand

Barand
  • Moderators
  • Sen . ( ile || sei )
  • 18,017 posts

Posted 10 September 2006 - 11:46 PM

remove ';' from beginning of

extension=php_gd2.dll

in php.ini file.

Make sure php_gd2.dll is in c:/php/extensions folder (assuming you used default installation path of c:/php when you installed PHP.

That should do it.

If not, check "extensions_dir" setting in your php.ini file and put dll in that folder.

If you are still using mysql_ functions, STOP! Use mysqli_ or PDO. The longer you leave it the more you will have to rewrite.

Donations gratefully received






moon.png

|baaGrid| easy data tables - and more
|baaChart| easy line, column and pie charts

#7 ahmed17

ahmed17
  • Members
  • PipPipPip
  • Advanced Member
  • 59 posts

Posted 11 September 2006 - 03:04 PM

remove ';' from beginning of

extension=php_gd2.dll

in php.ini file.

Make sure php_gd2.dll is in c:/php/extensions folder (assuming you used default installation path of c:/php when you installed PHP.

That should do it.

If not, check "extensions_dir" setting in your php.ini file and put dll in that folder.

no result appear and when i use phpinfo() to ensure if gd support or not  it appear with all lib 
so wat i do :-\ ??? ?

#8 Barand

Barand
  • Moderators
  • Sen . ( ile || sei )
  • 18,017 posts

Posted 11 September 2006 - 07:25 PM

Does it work if you put the dll in same folder as php.exe (c:/php if default install)
If you are still using mysql_ functions, STOP! Use mysqli_ or PDO. The longer you leave it the more you will have to rewrite.

Donations gratefully received






moon.png

|baaGrid| easy data tables - and more
|baaChart| easy line, column and pie charts




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users