Jump to content

Archived

This topic is now archived and is closed to further replies.

Love2c0de

Setting up server in Aptana

Recommended Posts

Good morning guys,

 

Just wondering if you could possibly help me setup my WAMP server to work with Aptana 3?

 

I have googled it and found a response from another blog type website and have tried what they said but to no avail.

 

I have setup my workspace to be in C:\wamp\www.

 

I have opened up my files in Aptana from the www\ folder, the same ones I had in my text editor.

 

I went to Window -> Preferences and then Aptana Studio -> Web Servers and created a new web server.

 

For the name I put 'Coder'.

 

For the Base URL I put http://localhost

 

For Document Root I put C:\wamp\www

 

Not sure what I am doing wrong, when I try to run my index.php using the 'Run' button, it is opening up the file in FF and prompting for download.

 

When I go to 'Run Configurations' and the 'Web Browser' node and click on the FF one, when I select 'Use selected server' and choose the one which I created nd try to run FF, it brings up an error saying: "'Launching Firefox - Internal Server' has encountered a problem. Generic server doesn't suport start". It is only when I choose 'Use built-in web server' in the configurations that it actually opens up firefox but then as stated it prompts for download.

 

The link which is in the address bar when FF opens and prompts for download is this : file:///C:/wamp/www/Fathers/index.php

 

Please help me, I really want to give IDE's a chance and I can't get this to work (first timer) :sweat:

 

Thanks in advance,

 

Regards,

 

L2c.

 

 

Share this post


Link to post
Share on other sites

Update,

 

Now I am getting the files to open up in the browsers ok only when I select 'Use built-in web server' though and my PHP code isn't executing.

 

The url in the address bar now is: http://127.0.0.1:8020/Single-Fathers/index.php

 

Anyone know what I am doing wrong? When I select the server which I set up it is still bringing up the error dialog with the message stated in my previous post.

 

Kind regards,

 

L2c.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.