Jump to content
dil_bert

banana pi - i have connected all the wires - no signal

Recommended Posts

hello dear all

 

on banana pi - i have connected all the wires

but:  no signal on screen

what  can i do now - plz advice

Share this post


Link to post
Share on other sites

I once got a call-out from a client who was having a problem printing his spreadsheet. When I got there I switched on his printer and it worked great after that.

Is your screen switched on?

Share this post


Link to post
Share on other sites

hello dear Barand

first of all - many many thanks - yes the screen is switched on....

 

i will try to digg deeper - and try to find out whats going on here...

Share this post


Link to post
Share on other sites

hello dear Barand,

found an very very interesting thread:

 

see https://www.raspberrypi.org/forums/viewtopic.php?t=34061 presume, you have installed your selected OS on SD card. Boot sector of the SD card is normally accessible from Windows, so you can edit file config.txt. What you maybe need? Add into config.txt this line:

Code: Select all

hdmi_force_hotplug=1

 

well - this can be a good hint..

Share this post


Link to post
Share on other sites

btw found some additonal texts:

 

https://raspberrypi.stackexchange.com/questions/2169/how-do-i-force-the-raspberry-pi-to-turn-on-hdmi

Add these two lines to /boot/config.txt and reboot Raspbmc:


 

hdmi_force_hotplug=1
hdmi_drive=2

 

hdmi_force_hotplug=1 sets the Raspbmc to use HDMI mode even if no HDMI monitor is detected. hdmi_drive=2 sets the Raspbmc to normal HDMI mode
(Sound will be sent if supported and enabled). Without this line, the Raspbmc would switch to DVI (with no audio) mode by default.

config.txt is read by the GPU so it will work on every distro.

There's two ways to do it. In older Pi installs, use the fb0 framebuffer when you want to display stuff on the HDMI/TV display, for example: FRAMEBUFFER=/dev/fb0 startx will use the HDMI/TV framebuffer for X windows instead of the PiTFT

On Jessie Pi installs, run sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf to edit the configuration file and make sure it contains: Copy Code

 

Section "Device"
  Identifier "display"
  Driver "fbdev"
  Option "fbdev" "/dev/fb0"
EndSection

 

change the Option "fbdev" "/dev/fb0" line to Option "fbdev" "/dev/fb1" if you want the xdisplay on the PiTFT or fb1 to fb0 for HDMI output.Update: If don't see the code above in the file, then simply copy and paste what is shown in this answer at the bottom of that file. If you can't find 99-fbdev.conf file in that folder, then there is probably another file with different name like 10-evdev.conf in
the same folder which you will have to modify to make it work as described above.

 

welll i did deeper into this issues

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.