Jump to content

Need help with renewing SSL certificate on custom port


Recommended Posts

Can someone please, please help me to fix my issue with enabling SSL.
I installed Azuracast (radiopanel) for almost 1 year ago, and all worked great.

I'm not sure whats happend the last month, cause i have issues with creating new SSL-certs.
Azuracast is installed on an own server, (behind port 8443).

I have a separate server from before which already uses ports 80 and 443 for websites etc. Therefore I am forced to use a custom port for Azuracast.

Again, everything worked fine from the start, don't ask me how.
But now the radio stream does not work, due to no SSL certificate.

I get the following error when I try to create a new certificate in the Azuracast panel:
Challenge validation failed: IP HERE: Invalid response from https://MY-DOMAIN/.well-known/acme-challenge/xYQP7DEJ-85ao70juwq7jtAXjXUE4e0dMZRhFltBuSE: 404 (urn:ietf:params:acme:error:unauthorized) at /var/azuracast/www/vendor/skoerfgen/acmecert/src/ACMEv2.php:145)"}

Link to comment
Share on other sites

Is whatever server is running on port 80 using the same domain?  Let's encrypt doesn't all alternate port numbers so you either need to be able to validate the domain using the server on port 80, or use an alternative verification method such as DNS verification.  Once the certificate is validated on port 80, you can use it with other ports just fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.