Jump to content

Archived

This topic is now archived and is closed to further replies.

janggu

Apostrophe problem after sending email

Recommended Posts

Hi there,

I used some PHP script for sending email but found a problem. When I type an apostrophe in textrea, I get email like following.

Typed : Let's go
Delivered: Let\'s go

Does anyone have any idea why it is happening?

Thank you.

Share this post


Link to post
Share on other sites
You have magic quotes (see [a href=\"http://www.php/net/get_magic_quotes_runtime\" target=\"_blank\"]get_magic_quotes_runtime[/a]) turned on in your php.ini file. Use the function [a href=\"http://www.php.net/stripslashes\" target=\"_blank\"]stripslashes[/a]() to remove the slashes.

Ken

Share this post


Link to post
Share on other sites
Thanks a lot! That resolved the issue. However, I have another problem that the text is broken up.

"You men tioned in your last message that he should register again in order to receiv e the"

I tried to find a pattern and looks like it happens every 14 characters.

Please help!!! :(

[!--quoteo(post=362631:date=Apr 7 2006, 07:22 PM:name=kenrbnsn)--][div class=\'quotetop\']QUOTE(kenrbnsn @ Apr 7 2006, 07:22 PM) [snapback]362631[/snapback][/div][div class=\'quotemain\'][!--quotec--]
You have magic quotes (see [a href=\"http://www.php/net/get_magic_quotes_runtime\" target=\"_blank\"]get_magic_quotes_runtime[/a]) turned on in your php.ini file. Use the function [a href=\"http://www.php.net/stripslashes\" target=\"_blank\"]stripslashes[/a]() to remove the slashes.

Ken
[/quote]

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.