Jump to content


Photo

Zip dll

php dll

Best Answer mac_gyver, 09 April 2014 - 01:37 AM

a) are you sure you even need the php_zip extension? it's only required by PHPExcel in some cases.

 

b) what sort of problem are you having with PHPExcel? it might not have anything to do with the zip extension.

 

c) have you checked if the php.ini that you are changing is the one the php is using? the Loaded Configuration File output from a phpinfo() statement is the php.ini that php is using.

 

d) is the zip extension currently being loaded? there wound be a section present for it in the output from a phpinfo() statement.

 

e) have you checked your web server's error log for any relevant php_zip.dll errors, that was mentioned as something to do in the replies above in this thread?

 

f) have you done or checked the other things mentioned in the replies above in this thread?

 

g) we only see the information that you supply in your posts and when you don't include information about what is occurring and what you have checked and what symptoms or errors you are getting, we cannot help because we don't have any feedback from you that narrows down the problem.

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 jimneely

jimneely

    Member

  • Members
  • PipPip
  • 13 posts
  • LocationDurham, NC - USA

Posted 04 April 2014 - 11:36 PM

I can not get the php_zip.dll set. here is what I have in my ini

 

extension=php_zip.dll

extension_dir = "C:\php\ext"

 

This should work but it does not. I am trying to get PHPExcel to run.



#2 requinix

requinix

    Transforming Moderator

  • Moderators
  • 6,027 posts
  • LocationWA

Posted 05 April 2014 - 01:58 AM

Is C:\php\ext the right location? Have you restarted your web server since enabling the extension? Checked error logs?

#3 Ch0cu3r

Ch0cu3r

    Advanced Member

  • Moderators
  • 2,220 posts

Posted 05 April 2014 - 10:16 AM

Are your sure php_zip.dll came with your PHP installation? Check that this file exists in your PHP extension folder (C:/php/ext).

 

If you cant find that file then you can download this extensions from here. Download the version that matches your PHP version 



#4 jimneely

jimneely

    Member

  • Members
  • PipPip
  • 13 posts
  • LocationDurham, NC - USA

Posted 08 April 2014 - 11:54 PM

The php_zip.dll is in c:\php\ext. I have tried moving it to c:\php with no luck. I have put quotes around it and removed with no change. this is so simple what am I missing



#5 mac_gyver

mac_gyver

    Advanced Member

  • Administrators
  • 2,441 posts

Posted 09 April 2014 - 01:37 AM   Best Answer

a) are you sure you even need the php_zip extension? it's only required by PHPExcel in some cases.

 

b) what sort of problem are you having with PHPExcel? it might not have anything to do with the zip extension.

 

c) have you checked if the php.ini that you are changing is the one the php is using? the Loaded Configuration File output from a phpinfo() statement is the php.ini that php is using.

 

d) is the zip extension currently being loaded? there wound be a section present for it in the output from a phpinfo() statement.

 

e) have you checked your web server's error log for any relevant php_zip.dll errors, that was mentioned as something to do in the replies above in this thread?

 

f) have you done or checked the other things mentioned in the replies above in this thread?

 

g) we only see the information that you supply in your posts and when you don't include information about what is occurring and what you have checked and what symptoms or errors you are getting, we cannot help because we don't have any feedback from you that narrows down the problem.


multi-purpose programming fool. well written source-code should be self-documenting. well written code should be self-troubleshooting. 


#6 jimneely

jimneely

    Member

  • Members
  • PipPip
  • 13 posts
  • LocationDurham, NC - USA

Posted 09 April 2014 - 03:41 AM

here

 

  • I have the php_zip.dll in the c:\php\ext.... I tried moving to C:\php and no results...
  • Apache 2.2 I have the directory set to c:\php\ext with the extension unsemicoloned.. actually I had to add the extension.
  • the 227 error is present in the Apache error log
  • it might be the wrong ini file,,, but I am changing php.ini in my C:\php, I think this is the correct file.

What so confusing is this is a no brainer something so easy...



#7 jimneely

jimneely

    Member

  • Members
  • PipPip
  • 13 posts
  • LocationDurham, NC - USA

Posted 09 April 2014 - 03:52 AM

OMG

I was changing the wrong php ini file. I was changing the php.ini and not the php.

 

 

Thanks Mac_gyver !!!!!!!!!!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Cheap Linux VPS from $5
SSD Storage, 30 day Guarantee
1 TB of BW, 100% Network Uptime

AlphaBit.com