Jump to content

Search the Community

Showing results for tags 'asp.net'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to PHP Freaks
    • Announcements
    • Introductions
  • PHP Coding
    • PHP Coding Help
    • Regex Help
    • Third Party Scripts
    • FAQ/Code Snippet Repository
  • SQL / Database
    • MySQL Help
    • PostgreSQL
    • Microsoft SQL - MSSQL
    • Other RDBMS and SQL dialects
  • Client Side
    • HTML Help
    • CSS Help
    • Javascript Help
    • Other
  • Applications and Frameworks
    • Applications
    • Frameworks
    • Other Libraries
  • Web Server Administration
    • PHP Installation and Configuration
    • Linux
    • Apache HTTP Server
    • Microsoft IIS
    • Other Web Server Software
  • Other
    • Application Design
    • Other Programming Languages
    • Editor Help (Dreamweaver, Zend, etc)
    • Website Critique
    • Beta Test Your Stuff!
  • Freelance, Contracts, Employment, etc.
    • Services Offered
    • Job Offerings
  • General Discussion
    • PHPFreaks.com Website Feedback
    • Miscellaneous

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Age


Donation Link

Found 4 results

  1. Dear all, I'm installing mod_aspdotnet on Apache, but for some reason, it doesn't run. I have mod_aspdotnet 2.2.0.2006. I try to run it on WAMP 2.4, Apache 2.4.4, and .Net version 4 (including the previous versions). I put the aspdotnet config in separate file in httpd.conf in httpd-aspdotnet.conf: Apache won't up so that it doesn't spew log on apache_error.log. Anybody has an idea how to troubleshoot this? regards, ethereal1m
  2. Dear PHPFreaks, Nice to meet you all! It is my first time right now on this nice communication full website. My technics are: -ASP.net -PHP -HTML5 -MySq -CSS 1 till 3 and a lot of more stuff! Regards, Mrbagino
  3. Hello. My mission is to develop a client to a third party's webservice, which server machine and source codes I can't access or handle. All I have is the API specifications and the addresses. The program works fine on DevelopEnvironment without authentication, but at ProductionEnvironment it requires basic http authentication plus certificate, and then I can't even receive any answer. They said me that I could use a self-signed certificate, so I've created one in my Server ( CentOS Apache2+PHP5.3.3 ). The company sent me a functional DotNetServiceClient piece of code, which includes the app.config which follows bellow. I need some example of how to send this authentication and more the certificate in PHP SoapClient or CURL. Here is the C# application's app.config, with fake IP and certificate: <?xml version="1.0" encoding="utf-8" ?> <configuration> <system.net> <settings> <servicePointManager expect100Continue="false" /> </settings> </system.net> <system.serviceModel> <bindings> <wsHttpBinding> <binding name="WSHttpBinding_ISyasAutoServices"> <security> <message clientCredentialType="UserName" /> </security> </binding> </wsHttpBinding> </bindings> <client> <endpoint address="http://200.200.200.200/Auto/WebServiceAuto/SyasAutoServices.svc" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_ISyasAutoServices" contract="ServiceReference1.ISyasAutoServices" name="WSHttpBinding_ISyasAutoServices"> <identity> <certificate encodedValue="AwAAAAEAAAAUAAAAmqc2gWanBIqn7sbzoxWEw==" /> </identity> </endpoint> </client> <behaviors> <endpointBehaviors> <behavior> <clientCredentials> <serviceCertificate> <authentication certificateValidationMode="None" revocationMode="NoCheck"/> </serviceCertificate> </clientCredentials> </behavior> </endpointBehaviors> </behaviors> </system.serviceModel> </configuration> And here is my current client code: /* PHP WebService Client */ $connectionParameters = array( 'login' => 'login' ,'password' => 'password' ,'trace' => TRUE ,'encoding' => 'UTF-8' ,'exceptions' => TRUE ,'cache_wsdl' => WSDL_CACHE_NONE ,'soap_version' => SOAP_1_2 ,'local_cert' => file_get_contents('/my/certificate/directory/selfsignedcertificate/thatwebservice.pem') ,'passphrase' => 'd3e343der434wds' ); $theClient = new SoapClient($serverWSDLURL, $connectionParameters); $r = $theClient->GetBasicWorkData(); The answer: No answer! Only timeOut. Any example or tip? Thank you very much.
  4. Hi! I have a webservice in asp.net that return Content-Type: application/soap+xml; charset=utf-8 Content-Length: length <?xml version="1.0" encoding="utf-8"?> <soap12:Envelope xmlns:xsi="http://www.w3.org/20...chema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap12="http://www.w3.org/20...soap-envelope"> <soap12:Body> <CalculadoraResponse xmlns="http://tempuri.org/"> <CalculadoraResult> <xsd:schema>schema</xsd:schema>xml</CalculadoraResult> </CalculadoraResponse> </soap12:Body> </soap12:Envelope> I call the webservice: <?php $client = new SoapClient("webserviceaddress"); $result = $client->Calculadora(array('Param1'=>'1')); $simpleresult = $result->CalculadoraResult; ?> How can i read the result? I have another function in that webservice that return a string and everything its ok, but with this function i dont know how to read the result
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.