Jump to content

Stuck on Xampp Splash Page


ShoeLace1291
 Share

Recommended Posts

I just installed Ubuntu Linux today and Xampp right after.  I got everything working, except for Xampp.  Localhost loads fine and takes me to the Xampp language selection splash page, but none of the links work and I'm stuck at that page.  I have absolutely no idea as to why this is happening.  Any ideas?

Link to comment
Share on other sites

  • 7 months later...
  • 3 months later...
  • 2 weeks later...

I got stuck on the splash screen aswell. probably because I removed first successful xampp installation and tried to re-install.

How to individually install all apache, mysql and ftp ?

This will get you a basic lamp stack:

yum install httpd mysql-server php-mysql php-gd php-mbstring

 

Don't use FTP if you don't need it. Start the SSH service and use WinSCP.

Link to comment
Share on other sites

  • 2 weeks later...

I feel that, there are permission issues.

 

You can install php, mysql and Apache

Please follow th steps.

Install Apache

 

To start off we will install Apache.

 

1. Open up the Terminal (Applications > Accessories > Terminal).

 

2. Copy/Paste the following line of code into Terminal and then press enter:

 

sudo apt-get install apache2

 

3. The Terminal will then ask you for you're password, type it and then press enter.

 

Testing Apache

 

To make sure everything installed correctly we will now test Apache to ensure it is working properly.

 

1. Open up any web browser and then enter the following into the web address:

 

http://localhost/

 

You should see a folder entitled apache2-default/. Open it and you will see a message saying "It works!" , congrats to you!

 

Install PHP

 

In this part we will install PHP 5.

 

Step 1. Again open up the Terminal (Applications > Accessories > Terminal).

 

Step 2. Copy/Paste the following line into Terminal and press enter:

 

sudo apt-get install php5 libapache2-mod-php5

 

Step 3. In order for PHP to work and be compatible with Apache we must restart it. Type the following code in Terminal to do this:

 

sudo /etc/init.d/apache2 restart

 

 

Test PHP

 

To ensure there are no issues with PHP let's give it a quick test run.

 

Step 1. In the terminal copy/paste the following line:

 

sudo gedit /var/www/testphp.php

 

This will open up a file called phptest.php.

 

Step 2. Copy/Paste this line into the phptest file:

 

<?php phpinfo(); ?>

 

Step 3. Save and close the file.

 

Step 4. Now open you're web browser and type the following into the web address:

 

http://localhost/testphp.php

 

The page should look like this:

 

Test PHP Page

 

Congrats you have now installed both Apache and PHP!

 

 

Install MySQL

 

To finish this guide up we will install MySQL. (Note - Out of Apache and PHP, MySQL is the most difficult to set up. I will provide some great resources for anyone having trouble at the end of this guide.)

 

Step 1. Once again open up the amazing Terminal and then copy/paste this line:

 

sudo apt-get install mysql-server

 

Step 2 (optional). In order for other computers on your network to view the server you have created, you must first edit the "Bind Address". Begin by opening up Terminal to edit the my.cnf file.

 

gksudo gedit /etc/mysql/my.cnf

 

Change the line

 

bind-address = 127.0.0.1

 

And change the 127.0.0.1 to your IP address.

 

Step 3. This is where things may start to get tricky. Begin by typing the following into Terminal:

 

mysql -u root

 

Following that copy/paste this line:

 

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('yourpassword');

 

(Make sure to change yourpassword to a password of your choice.)

 

Step 4. We are now going to install a program called phpMyAdmin which is an easy tool to edit your databases. Copy/paste the following line into Terminal:

 

sudo apt-get install libapache2-mod-auth-mysql php5-mysql phpmyadmin

 

After that is installed our next task is to get PHP to work with MySQL. To do this we will need to open a file entitled php.ini. To open it type the following:

 

gksudo gedit /etc/php5/apache2/php.ini

 

Now we are going to have to uncomment the following line by taking out the semicolon (;).

 

Change this line:

 

;extension=mysql.so

 

To look like this:

 

extension=mysql.so

 

Now just restart Apache and you are all set!

 

sudo /etc/init.d/apache2 restart

 

 

Link to comment
Share on other sites

  • 2 years later...

When I type in .. mysql -u root

I get the error message saying ..

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

 

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('wouldntyouliketoknow');

I get the error message ....

bash: error sintáctico cerca del elemento inesperado `('
Which basically means sintatic error near the unexpected element `(' ...

 

Please assist, ty

 

 

 

 

 

Link to comment
Share on other sites

Open up a console and try next steps:

mysql -h localhost -u root -p
password:  # if it's empty press "ENTER"

mysql> use mysql;
mysql> update user set password=PASSWORD("insert-the-new-root-password") where User='root';
mysql> flush privileges;
mysql> quit;

# restart the mysql server for every case and try to log in again

Link to comment
Share on other sites

This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.