Jump to content


Photo

dreamweaver problem


  • Please log in to reply
3 replies to this topic

#1 Zane

Zane
  • Administrators
  • Advanced Member
  • 4,134 posts

Posted 06 December 2004 - 10:24 PM

I know my question has nothing to do with PHP but this forum is the most active and I go here all the tme for my answers.

That being said
---------------------------------------------------------

I'm using Dreamweaver MX 2004 to edit a site
and I'm uploading it to an IIS 6.0 web server

In dreamweaver when you want to link a word to another page you can either type it or you can click the small target button beside the link textbox and drag it to the desired file, thus linking the file automatically.

What I don't like about this is that when I try and link lets say Contact to the file contact.htm which is in the same folder it will put "/contact.htm" notice the preceding slash....
This is when I'm in a subdirectory

By having that slash there IIS somehow interprets is as.......go to the root directory...so it links more like this "[rootdir]/contact.htm". it doesn't put the domain in the html or anything it just links back to the root.
I want it to say "contact.htm" without the slash but that is where my problem and question is.

(The odd thing is that when and if I upload it to a apache server the way it is.....then it works fine. Like always the problem is Microsoft)

Is there a way to change the way dreamweaver links the files?

If you still don't understand what I'm talking about then ask me.

btn_donate_SM.gif Want to thank me? Contribute to my PayPal piggy-bank
 

172938.png

#2 sonjay

sonjay
  • New Members
  • Pip
  • Newbie
  • 4 posts
  • LocationThe Hurricane State

Posted 07 December 2004 - 12:27 AM

The next time you make a link, instead of dragging the little thingie, click the folder icon next to it, and browse for the file you want to link to. Now, before you close that dialog box, look for the option down in the bottom left that asks whether you want the link to be "Relative to Site" or "Relative to Document." Choose "Document."

That's a sticky option. From now on, all your links will be document-relative.

#3 Zane

Zane
  • Administrators
  • Advanced Member
  • 4,134 posts

Posted 07 December 2004 - 05:52 AM

Awesome.......that did exactly what I wanted..
Now I don't have to do a search and replace for the entire site or use

"./" to refer to a file within the same directory..


Thank you

btn_donate_SM.gif Want to thank me? Contribute to my PayPal piggy-bank
 

172938.png

#4 Roberto

Roberto
  • Members
  • PipPip
  • Member
  • 16 posts
  • LocationLondon, England

Posted 14 December 2004 - 03:38 PM

Now I don't have to do a search and replace for the entire site or use


You still might have to do this. This option is only for new links you create, any links you have already created won't be changed by changing this option.

Rob
*************************************
Mad Mouse Media Web Design
t: (+34) 610 837 558
e: rob@madmousemedia.co.uk
w: www.madmousemedia.co.uk
w: www.madmouseart.com *************************************




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users