Jump to content

Archived

This topic is now archived and is closed to further replies.

Special-K

Access denied for user: 'root@localhost'

Recommended Posts

Hi

 

before i start im a newbie :oops:

 

Can any body help me with this problem..

 

i have installed apache ( working fine ) , php ( php test page i made works fine but phpinfo.php does not show up ) , mysql and mysql admin

 

but when i try to access sql i get this error

 

Access denied for user: \'root@localhost\' (Using password: YES)

 

why do i keep getting this error , i know the pass :P - but it keeps coming up..

 

thanks :D

Share this post


Link to post
Share on other sites

did you set up a password? try entering no password at all and see if that solves your problem

Share this post


Link to post
Share on other sites

Yes i tryed it with and without a pass

 

i.e - example

 

[WinMySQLadmin]

Server=C:/mysql/bin/mysqld-nt.exe

user=root

password=passhere

 

 

and

 

[WinMySQLadmin]

Server=C:/mysql/bin/mysqld-nt.exe

user=root

password=

 

is this what you ment m8 - like i said im a noob ;)

Share this post


Link to post
Share on other sites

yeh, i meant that, i installed mysql apache and php on my pc at home and it tells me not to enter a password at all! i got the saem errors as you at first! till i realised!

 

But if you have tried I dunno what else!

 

Soz im a noob to :-)

Share this post


Link to post
Share on other sites

np m8 - we have to learn :D

 

anyway please help guys.

 

im still having the same prob here apache and php are fine but mysql just will not happen for me :P

 

:?:

Share this post


Link to post
Share on other sites

You need to ensure that you either reload or restart MySQL after adding users, changing database permissions or passwords. Reload MySQL and give it another shot :)

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.