Jump to content

Archived

This topic is now archived and is closed to further replies.

andreea115

help installing Zend 1.12 to window 7 with WAMP Server 2.2

Recommended Posts

Hi everyone.

i am having problems loading zend framework 1.12 to my windows 7
 
i keep getting this error message:
 
 
"php.ex" is not recognized as an internal or external command, operable program or batch file".
 
perhaps it will be easier if i tell you how i installed it and someone can please tell me where i have gone wrong.
 
i installed Zend Librairies and bin in the following folders in my laptop ( windows 7) :

C:\wamp\bin\php

this bin folder is the same folder that my PHP5.43 is held in. The Zend is held in a folder called: zendframwork

i then went to my php.ini folder ( includes path- ) and inserted the following:

include_path = ".;C:\wamp\bin\php\zendframwork1.12\library"

i then went to change my advanced windows settings: once there, i clicked onto Environment Variables , then to System variable where i double clicked on to paths line.

in the paths line i include the path to the bin folder for the zend bin ie: Control Panel\System and Security\System

;C:\wamp\bin\php\zendframwork1.12\bin

i then ok' ed everything and then went to my windows powershell interface. i.e

"Administrator: Windows Powershall"

once there i typed in zf ( i did this to test whether the system would recognize that zend has been install. )

however, i keep getting the following message:

"php.ex" is not recognized as an internal or external command, operable program or batch file".

Can someone please tell me what this message means and what i need to do to correctly configure Zend on my machine.

warm regards

Andreea

Share this post


Link to post
Share on other sites

I am also building a website based on Zend Framework 1.12 (ZF) and I have installed ZF with xampp not WAMP as you do. 

But I still share my experience with you and hope it will help you install ZF successfully.

 

Your include_path should be as the following: (\library truncated)

include_path = ".;C:\wamp\bin\php\zendframwork1.12"

Assuming the path to your file php.exe is:

C:\wamp\php

You must set a System variable named path as the following: C:\wamp\php. This variable will point to php.exe

 

You must copy three following important files of Zend and paste them into the folder C:\wamp\php

 

  1. zf.bat
  2. zf.php
  3. zf.sh

You must set a System variable named zend_tool_include_path. Its value should be C:\wamp\bin\php\zendframwork1.12\library. This variable will point to Zend library that has been installed.

 

Maybe you need restart your windows.

 

To test whether Zend is recognized, you run cmd.exe, moving to C:\ and typing:

 

C:\> zf show version

 

If you get the answer such as: Zend Framework Version: 1.12.0, that demonstrates ZF has been successfully installed. 

Share this post


Link to post
Share on other sites

same here i got a problem and show message as follow: 

Fatal error: Uncaught exception 'RuntimeException' with message 'Unable to load ZF2. Run `php composer.phar install` or define a ZF2_PATH environment variable.' in C:\xampp\htdocs\zendyou\init_autoloader.php:48 Stack trace: #0 C:\xampp\htdocs\zendyou\public\index.php(9): require() #1 {main} thrown in C:\xampp\htdocs\zendyou\init_autoloader.php on line 48

and a don't know to solve this. could you please help what to.

Share this post


Link to post
Share on other sites

hello  dungpt29

 

thank you very much for your recommendation. Just a quick question before i try it:

 

Did you mean that i should run a system variable as such:

 

zend_tool_include_path=C:\wamp\bin\php\zendframwork1.12\library

 

or

$zend_tool_include_path=C:\wamp\bin\php\zendframwork1.12\library

 

please tell me if this is the correct syntax.

 

warm regards

 

Andreea

Share this post


Link to post
Share on other sites

Hello dungpt29

 

i followed your recommendation but it still does not work. i still get the following error message

 

******ZF Error  ******

In order to run the zf command, you need to ensure that Zend Framework is inside your  include_path.

The  easiet way.... include path via an environment viariavble ZEND_TOOL_INCLUDE_PATH

 

Do you know why its still doing this. is there a way for me to check the exact path to the library folder?

 

thanks for your kind help thus far

 

warm regards

 

Andreea

Share this post


Link to post
Share on other sites

I guess that your folder set-up for Zend library is wrong from the beginning. 

 

I still assume the path to php.exe is:

C:\wamp\php

You need create a new folder named includes for example. Its path will be:

C:\wamp\php\includes

You move your Zend library into includes folder. The path to this library will be:

C:\wamp\php\includes\library

You edit the value of Environment variable  zend_tool_include_path and set it to the following value:

C:\wamp\php\includes\library

You also edit include_path in php.ini as the following:

include_path = ".;C:\wamp\bin\php\includes"

Share this post


Link to post
Share on other sites

Why are you all using an old version of Zf?

Share this post


Link to post
Share on other sites

Hi trq

 

There are two reasons why i am using an older version.

 

1. i am a newbie to Zend and therefore trying to learn how to use it: however, all the leading books on Zend focus entirly on Zend 1 i.e   'Zend in Action' by Rob Allen, 'Zend framework' by Vikram Vaswani and 'easy PHP Website with the Zend framework' by Jason Gilmore

 

2. many of the leading sites, that have already built with the Zend framework,  are built using Zend 1;  for example, i have just started work on some existing projects in zend and they were both built in Zend1.

 

Accordingly, for the foreseeable future, i feel that its necessary to be able to work with both versions of the framework.

 

warm regards

 

Andreea

Share this post


Link to post
Share on other sites

Hi trq,

 

I have been studying and building a website based on ZF1 for 4 months.

 

I find that ZF1 library is larger and more suitable for the beginners than ZF2's one. 

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.