Jump to content

Archived

This topic is now archived and is closed to further replies.

lilmer

Rewrite WWW to https Problem

Recommended Posts

Hello I have problem on redirecting the site to https when it comes to "www.site.com". 

 

I made this

 <rules>                  
              <rule name="Redirect site.com to www" patternSyntax="Wildcard" stopProcessing="true">
                     <match url="*" />
                         <conditions>
                              <add input="{HTTP_HOST}" pattern="site.co" />
                         </conditions>
                         <action type="Redirect" url="https://www.site.co/{R:0}" />
               </rule>
</rules>

In this sample when I try to access the site through "site.com" it redirect to " https://www.site.com " but when I access the site to www.site.com the https doesn't appear.  

Share this post


Link to post
Share on other sites

Okay got  the correct URL rewrite.

 

<rule name="Redirect to HTTPS" stopProcessing="true">
<match url="(.*)" />
<conditions><add input="{HTTPS}" pattern="^OFF$" />
</conditions>
<action type="Redirect" url="https://{HTTP_HOST}/{R:1}" redirectType="SeeOther" />
</rule>

Share this post


Link to post
Share on other sites

I've never seen rewrite rules like this. What kind of server is this used on?

Share this post


Link to post
Share on other sites

I've never seen rewrite rules like this. What kind of server is this used on?

This is the IIS board.

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.