Jump to content

Archived

This topic is now archived and is closed to further replies.

afimafis

PHP Curl Proxy Problem

Recommended Posts

Hello,

 

hello i need use curl with proxy. but i get "undefined variable offset 1" error . here is the standart code i use.

please help me about it

 

thanks

 

 

curl_setopt($ch, CURLOPT_URL, $url); curl_setopt($ch, CURLOPT_HEADER, $header); curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1); curl_setopt($ch, CURLOPT_PROXY, $proxy); curl_setopt($ch, CURLOPT_HTTPPROXYTUNNEL, 1); curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout); curl_setopt($ch, CURLOPT_REFERER, $referer); curl_setopt($ch, CURLOPT_USERAGENT, $agent);

Share this post


Link to post
Share on other sites

Post the entire error, the relevant code (ie, what is $proxy) and use code tags next time.

Share this post


Link to post
Share on other sites

 

jesirose thanks for reply :)

i am sure that proxy works well. but i guess problem is related curl proxy settings. codes are standart i used.

i will be very appreciated, if u give me any clues

 

thanks

 

Post the entire error, the relevant code (ie, what is $proxy) and use code tags next time.

Share this post


Link to post
Share on other sites

Post the entire error, the relevant code (ie, what is $proxy) and use code tags next time.

Share this post


Link to post
Share on other sites

 

the point i am sure is page can not loaded on time.even if i use timeout as 20 seconds

 

i dont know what i missed

 

thanks

Share this post


Link to post
Share on other sites

I've never seen someone so stubborn set against actually getting help. Impressive.

Share this post


Link to post
Share on other sites

sorry  :)

 

 

 

    //## Init cURL

    $ch = curl_init();

    curl_setopt($ch, CURLOPT_USERAGENT, "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.3; .NET4.0E; .NET CLR 1.1.4322)");

    curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);

curl_setopt($ch, CURLOPT_FRESH_CONNECT, 1);

    curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);

curl_setopt($ch, CURLOPT_PROXY, 202.182.124.12:3128);

    curl_setopt($ch, CURLOPT_HTTPPROXYTUNNEL, 1);

    curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout);

    curl_setopt($ch, CURLOPT_RETURNTRANSFER,1); 

    curl_setopt($ch, CURLOPT_COOKIEJAR, "cookie.txt");

    curl_setopt($ch, CURLOPT_COOKIEFILE, "cookie.txtt");   

 

    curl_setopt($ch, CURLOPT_URL, "https:..........................");  $page = curl_exec($ch);

print_r($page);

Share this post


Link to post
Share on other sites

If you add quotes around the proxy IP and add echo curl_error() at the end:

Received HTTP code 403 from proxy after CONNECT

 

You've used that proxy in your browser and it worked without authentication?

Share this post


Link to post
Share on other sites

sorry i forgot to add quatoes. but i am sure that it works on web browser. no errror gottten

Share this post


Link to post
Share on other sites

Don't set CURLOPT_HTTPPROXYTUNNEL. Take out that line.

Share this post


Link to post
Share on other sites

sorry i forgot to add quatoes. but i am sure that it works on web browser. no errror gottten

This makes me think of some weird combination of quotes and potatoes. Quoted potatoes guys.

Share this post


Link to post
Share on other sites

i will very happy, if u help me  :-\

 

 

sorry i forgot to add quatoes. but i am sure that it works on web browser. no errror gottten

This makes me think of some weird combination of quotes and potatoes. Quoted potatoes guys.

Share this post


Link to post
Share on other sites

Like I said before, take out this line:

curl_setopt($ch, CURLOPT_HTTPPROXYTUNNEL, 1); 

This proxy doesn't need it.

Share this post


Link to post
Share on other sites

Like I said before, take out this line:

curl_setopt($ch, CURLOPT_HTTPPROXYTUNNEL, 1); 

This proxy doesn't need it.

 

i tried but nothing changed :(

 

Share this post


Link to post
Share on other sites

Works for me.

$ch = curl_init();
curl_setopt($ch, CURLOPT_USERAGENT, "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.3; .NET4.0E; .NET CLR 1.1.4322)");
curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);
curl_setopt($ch, CURLOPT_FRESH_CONNECT, 1);
curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);
curl_setopt($ch, CURLOPT_PROXY, "202.182.124.12:3128");
// curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout);
curl_setopt($ch, CURLOPT_RETURNTRANSFER,1);
curl_setopt($ch, CURLOPT_COOKIEJAR, "cookie.txt");
curl_setopt($ch, CURLOPT_COOKIEFILE, "cookie.txtt");

curl_setopt($ch, CURLOPT_URL, "https://www.google.com");  
$page = curl_exec($ch);
echo $page;
echo curl_error($ch);

What error do you get now?

Share this post


Link to post
Share on other sites

i tested . works well for me. but i changed proxies. %90 of them gets this error

216.155.139.115:3128

117.27.139.17:80

 

i tested these proxies 5 minutes ago. they are level1 proxies

 

 

 

"Received HTTP code 403 from proxy after CONNECT"

 

 

 

Works for me.

$ch = curl_init();
curl_setopt($ch, CURLOPT_USERAGENT, "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.3; .NET4.0E; .NET CLR 1.1.4322)");
curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);
curl_setopt($ch, CURLOPT_FRESH_CONNECT, 1);
curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);
curl_setopt($ch, CURLOPT_PROXY, "202.182.124.12:3128");
// curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout);
curl_setopt($ch, CURLOPT_RETURNTRANSFER,1);
curl_setopt($ch, CURLOPT_COOKIEJAR, "cookie.txt");
curl_setopt($ch, CURLOPT_COOKIEFILE, "cookie.txtt");

curl_setopt($ch, CURLOPT_URL, "https://www.google.com");  
$page = curl_exec($ch);
echo $page;
echo curl_error($ch);

What error do you get now?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.