Jump to content
kicken

Forums preventing sleep

Recommended Posts

Anyone else noticing an issue where having the PHPFreaks forums open in the browser will prevent the computer from going to sleep with windows 10?  

Noticed that recently and checked with powercfg -requests and it seems whenever I have the forums open in a tab there's a request from the audio driver open that prevents sleep.  I'm assuming it's related to the notifications feature, even though I have that disabled afaik.

I don't use any other IPB based sites so no idea if it's just a bug with the software or what.  Request shows up with chrome, firefox, and edge so I don't think it's a browser bug.

 

Share this post


Link to post
Share on other sites

Windows 10 1909 here. I have sleep disabled (desktop computer) and powercfg says nothing is happening.
I normally have Chrome with the tab open, however most of the time the tab is in the background so eventually the forum stops polling for notifications (indicated by the pause ⏸ in the page title). And I do have desktop notifications enabled.

Obviously IPB itself can't tell your computer to not go to sleep...

What are your "advanced" power settings? Specifically under the Multimedia group. Here's mine:

image.png

Share this post


Link to post
Share on other sites

I think it may be this Firefox bug: Audio stream remains open when playback paused, preventing power saving/sleep

I re-checked chrome this time actually seeing if it would sleep vs just checking for the request and it did actually sleep.  It appears even though chrome causes the same audio request it does release it after a minute or so.  Firefox doesn't, so the system ends up staying on.

Not sure how IPB implements it's notification sound but I think it's triggering that bug.  Trying to figure it out in all the minified JS is something I don't really feel like doing.  I made a few attempts at re-producing it myself with <audio> or new Audio() but no luck.

 

Share this post


Link to post
Share on other sites

That does sound relevant.

Until it's fixed, you can turn off IPB's sounds through notification settings. Not sure exactly how it plays sounds - best guess being a temporary <audio> - but I think the "stream" term is a misnomer and it's more about the audio resource itself not releasing a sleep lock.

Share this post


Link to post
Share on other sites
13 minutes ago, requinix said:

you can turn off IPB's sounds through notification settings.

They are off, still happens though.  

It's not a big deal, just an oddity I noticed a while back.

 

Share this post


Link to post
Share on other sites
Just now, kicken said:

They are off, still happens though.

That's the only sound I know of that it could be playing...

Share this post


Link to post
Share on other sites

Don't know if this is connected but recently I have been working with another Invision-powered site. When connected to either taht site or Freaks site (even if the tab is not current tab) my broadband upload speed is crippled, sometimes dropping below 1Mbps. Both these sites repeatedly have the same effect and I have not seen it happen on any other sites.

Prior to connection

image.png.3bc2d22f8e78cfd51ec5a7f2e9bd375d.png

Connected to https://www.foxestalk.co.uk or Freaks

image.png.94329f7735b255260a4d387d98c0ea89.png

On closing the Invision tab the speed returns to normal. It seems the Invision software permanently hogs the line.

Edited by Barand

Share this post


Link to post
Share on other sites

I'm not sure how that's even possible... Like, there's no way a site should be able to cripple traffic like that without being totally obvious about lots of ongoing traffic.

Share this post


Link to post
Share on other sites

That doesn't look too unusual: periodic requests to look for new posts. Hopefully IPB will switch to websockets in the future...

Windows, right? Can you run TCPView, sort by one of the Sent/Rcvd Packets/Bytes columns, and see if maybe that helps explain what's going on?

Share this post


Link to post
Share on other sites

That is indeed an odd issue.   I can say that's not a problem I've experienced here.   Like requinix I struggle to think of a way such a problem could even happen without there just being some massive data stream going on in the background.

The best speculation I can come up with is something the form is doing ends up triggering some kind of rate-limiting rule on your ISP's network.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.