Jump to content

Annoying support


Recommended Posts

Small rant thread for some recent frustrations.

So a friend of mine has a few sites she has been trying to run using a third-party system she bought.  I've been providing some hosting for her for free on my VPS to help her save some money.

The software she has is kind of junk by modern standards I think.  Uses Zend Framework v1 and was probably written in the early php 5.x days originally.  For some reason she likes it even though she seems to be constantly opening support tickets for things.    Support was always slow to respond too and used to always complain that they couldn't access the site and work on it because I didn't have cPanel and phpMyAdmin setup.   Been better about that lately, I guess they got someone who knows how to use SFTP/SSH working there finally.

Recently she decided to buy their upgraded version for a new site.  Being a new major version I had hoped the code behind it had been improved but it doesn't seem that's the case.  I got it setup for her and she started trying to configure/customize it and ran into some issues almost immediately and opened tickets.  Rather than try and address the issue this time though they just responded:


Your server does not meet our requirements and the PHP version is too high. Please have your host check the requirements and once the server meets and does not exceed the requirements, please let us know and we can then check the rest of your issues too.

Version is too high?  Really? 😒 The server is setup for PHP 7.3.21.  The 7.3 branch isn't exactly cutting edge, I'd like to think a vendor selling still-updated software would support that.   They apparently only support 7.2 according to the requirements list they sent along.

Whatever though, I went ahead and downgrade her site for her to 7.2.  I include a little note for her to forward to their support though expressing my frustration:


According to the requirements page, 7.2 seems to be the only version allowed.  This is a problem the vendor needs to address as PHP 7.2 is already effectively end-of-life and will be officially end-of-life as of November 30th 2020 (https://www.php.net/supported-versions.php).

For an actively developed and paid-for product, there's really no excuse to not support PHP 7.3 and it should support PHP 7.4 at this point as well.

In the end they end up doing a re-install of the software for her and she starts over.  Ticket resolved.


Fast forward a few days, she submits a new ticket and again they decide to complain about the hosting setup.  This time:


There could be some issues resolved if moving to a recommended host or if your host conforms to the requirements.  The software does not support FCGI for one thing and your server is set up on that.

I have the server setup using PHP-FPM so each site can run under the appropriate user account rather than www-data.  Much nicer setup IMO and shouldn't make any difference.  As far as I can tell, the only thing affected in their application by not being run as an Apache module is that their installer script can't verify if mod_rewrite is enabled or not.  The script just says 'Unable to check' and shows it as a warning, you can still continue and install anyway.

I told her I wasn't going to change this.  They can just deal with it, and if they won't then she might just have to look at some of their recommended hosting.  She's still working on the site so I'm guessing they decided to deal with it.  Hopefully they are done blaming the hosting setup now, but who knows.


Link to comment
Share on other sites

13 hours ago, kicken said:

Version is too high?  Really? 😒

I upgraded to PHP 7.4 locally because duh. Recently I needed to deal with a Laravel 5.x app. Does it work on PHP 7.4? Yeah, even though it's an older version.

Well, almost worked. Somewhere in a plugin there was a call to implode() with the arguments backwards and support for that was E_DEPRECATED. Okay, deprecated, fine. But you see, in Laravel's infinite wisdom, it decided that every single error of any severity needs to be shoved into an ErrorException and thrown. So the entire application breaks down because of a single line in a single plugin that is still working perfectly fine, it just won't work "perfectly fine" after hypothetically changing the system configuration at some undetermined point in the future.

So yeah. "Version too high" is stupid.

Link to comment
Share on other sites

This thread is more than a year old. Please don't revive it unless you have something important to add.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.