Jump to content

Page content converted to incorrect characters for no reason!!


Recommended Posts

This is probably the wrong section to post this in, but I'm not sure where to post it, but I am using PHP, so I decided to post it here...


I started a simple website a few days ago using simple PHP, HTML, and CSS code. It worked just fine, up until a day or two ago when I started using cookies for settings, to test things out. Since then, my website and all of it's pages show up almost completely corrupt online. You can see for yourself at http://mysevertime.com/.


Most of the code is turned into foreign letters and invalid characters, while bits of it (like "<?php" and "<h1>MyServerTime.com</h1>") remain intact. It doesn't look like the server is even compiling the PHP either, because you can see remains of it in the source. I've tried reuploading and viewing from different domain names also connected to the same FTP, but the result is the same.


I removed all of the php from my files to see if that would make things different, but it doesn't. I don't think there's anything wrong with my FTP client, since it uploads other files fine. My editor couldn't be the problem either; it also saves other files normally.


What in the world is happening?!

Link to comment
Share on other sites

Augh, I always make mistakes like these. Yes, the url is http://myservertime.com.


It's all supposed to be English. For no apparent reason, it's showing up in Chinese, Japanese, other Asian languages, and various invalid characters.


When I click on the link, all I see is the number '1'.  Even in the view source...

Link to comment
Share on other sites

I also emailed my host, GoDaddy, about this and have just received a response:


Thank you for contacting Online Support.  Upon review of the issue it appears that this is going to be an issue with the scripting of the page.  Unfortunately we would be unable to provide assistance with this issue as we are unable to provide any scripting support.  I apologize for any inconvenience this may cause.


I don't see how this is a scripting issue at all. To prove it, I replaced the site contents with a fresh copy of WordPress, and got the exact same issue.

Link to comment
Share on other sites

Sorry for the triple post; the edit button has disappeared.


I figured out what the problem is. Apparently, the tiny button that enabled editing in Unicode was selected on my editor for my header file, which ultimately screwed up the entire website. And it still showed up corrupted when I tried to install a different script because my caches on Firefox, Chrome, Safari, Opera, and Internet Explorer all decided not to refresh.



Thanks for all the help everyone.

Link to comment
Share on other sites

This thread is more than a year old. Please don't revive it unless you have something important to add.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.