Jump to content

Archived

This topic is now archived and is closed to further replies.

webguync

cannot connect to server via PuTTy (SSH)

Recommended Posts

I am trying to connect to my Linux server via PuTTy on my windows desktop. I have so far been unsuccessful. I called tech support of my hosting company (Media Temple), and all they could tell me is they could connect themselves. I don't think they were using PuTTy though. I am using the default setting. And putting in the correct host name. Then when the login prompt comes up. I put in ssh root@ipaddress.com. I keep getting access denied. I verified that the password I use is correct. and I believe the settings I am using are correct. Any other way to troubleshoot?

Share this post


Link to post
Share on other sites

Unless this is your own dedicated server a hosting company will not let you login to a server as the root user. Get the correct username.

Also you just use the username to login without any @ipaddress whatever that is i.e

 

user: root

password: abcdef

Share this post


Link to post
Share on other sites

Don't mean to sound at all patronising but is there any firewall enabled on your server?

 

If so open port 22, I think though as someone else is looking after them you won't need to worry about security since they will defend against this, having it being their network as such.

 

I mean I use my own and use my routers software for my security (having it being a custom based PC for this task).

Share this post


Link to post
Share on other sites

Don't mean to sound at all patronising but is there any firewall enabled on your server?

 

If so open port 22, I think though as someone else is looking after them you won't need to worry about security since they will defend against this, having it being their network as such.

 

I mean I use my own and use my routers software for my security (having it being a custom based PC for this task).

 

Dedicated servers are generally hosted within a DMZ and all traffic is forwarded to them directly. It is usually the responsibility of the administrator to protect there own resources.

Share this post


Link to post
Share on other sites

No, the op is getting a prompt, this means the connection was successful.

Share this post


Link to post
Share on other sites

Describe exactly what it is your doing and what exactly is happening?

Share this post


Link to post
Share on other sites

sure, I open up PUTTY.EXE.

for the host name I put in the host domain (I also tried IP address). The Port is 22 and the connection type is SSH.

 

Per the instruction from my hosting provider for the login I should put in ssh root@serveripadress.com since it is a dedicated server.

 

I get an access denied message when I do this. I verified with the tech support of the hosting provider that what I am doing is correct.

 

 

 

Share this post


Link to post
Share on other sites

It is not correct via putty. On Linux you would use the ssh command to connect to an ssh server, via Windows you need to use a client called putty. Hence, typing 'ssh whatever' as your username makes no sense.

 

I suggest following the instructions neil.johnson posted several posts ago.

Share this post


Link to post
Share on other sites

I tried connecting using just the domain name  when I get prompted the login and that doesn't grant me access either.

Share this post


Link to post
Share on other sites

No, the op is getting a prompt, this means the connection was successful.

 

Sorry I am a bit asleep today, do you have a home directory and if not (just on the off chance of course) is your ssh setup from ./etc/ssh mean you have to have a valid directory to login? Some servers I have seen must require a home directory to login.

 

Apart from that I wouldn't know.

Share this post


Link to post
Share on other sites

don't know if this helps, but the server is hosted with Media Temple and it's a dedicated (DV) server. Here are the instructions they provide.

 

http://kb.mediatemple.net/questions/16/Connecting+via+SSH+to+your+server#dv

 

this is why i was doing the ssh root@70.32.86.175 deal. I was following their instructions. I even called them to make sure I was putting in the correct info and they said I was.

Share this post


Link to post
Share on other sites

First do this:

 

http://kb.mediatemple.net/questions/625/How+do+I+enable+root+access+to+my+%28dv%29%3F#dv

 

Now, in windows, open up putty. For the hostname put the server's IP address in, and select port 22. Click Open.

You should now get the login prompt.

 

For the username simply type: root

Press enter.

 

Enter the password that you setup for root by using the instructions in the link above.

Press enter.

 

Done.

Share this post


Link to post
Share on other sites

I appreciate the response, bu you know what? I tried that and still get access denied. And yes, I did make sure that I have root access enabled.

Share this post


Link to post
Share on other sites

You need to take this up with your host.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.