Jump to content

TzFiles


The Little Guy

Recommended Posts

Yeah, the pictures are nice for a family website... but not file hosting.

Agreed with the red underline.

Also, on your registration, you still need to check to see if it fits the criteria before searching to see if the username exists. Ex: I put in "king" and it said "that name is available.. blah blah...." It would be nice to have something to see if it fits the criteria, so when they click on "check name" that it would tell them.
Link to post
Share on other sites
The dog is my dog, and I had pictures, so i used them.

I don't understand what you mean about fitting the criteria, if its too short it will say so, if it is too long it will say so, otherwise it will say name is available, or name is taken. "king" was valid since it was 4 char, while "kid" is invalid.

What type of pictures would you have expected? I could then try to get some.

For the red underline, would you rather it be white like the text?
Link to post
Share on other sites
I would expect some kind of picture advertising why you should use your site or something. Not dogs and christmas trees. Maybe some kind of file icon or tree folder system.

As for hyperlinks, I usually just have an underline of the same color appear under the text on rollover. Navigation I would make the text a different color on rollover and no underline.
Link to post
Share on other sites
it does need a general tidy up, and as has been mentioned, the dog picture needs to be something more relevent to what you're doing.

overall, it just seems a little bland and needs more to keep a potential user interested.

Also, there is no "proper" validation on your forms.
Link to post
Share on other sites
I don't understand any of the main images you are using.  The folder icon should extend over the border IMO, would be nice. I don't like it cut off. It is very white with a lot of empty space, especially the background, that needs fixing. A simple pattern or color may help. Your registration form needs some spacing between fields, everything is cramped.
Link to post
Share on other sites
OK, I took some of your suggestions and changed it, I haven't yet gotten to those images you all are talking about yet though (dog, x-mas tree, etc.).

This isn't just a file host, it is also an image host.

you can use the demo if you would like (there is more stuff inside i would like tested/looked at):
username: demo
password: demo12
Link to post
Share on other sites
I didn't spend too much time on your site, but the first thing that I saw is that the overall size of your logo is too big and the white background of the image is going down into your gradient so it looks like there is a big chunk missing. If you make it a transparent gif, or crop it a little it should do the trick.

-Chris
Link to post
Share on other sites
[quote author=cmgmyr link=topic=121739.msg503501#msg503501 date=1168637274]
I didn't spend too much time on your site, but the first thing that I saw is that the overall size of your logo is too big and the white background of the image is going down into your gradient so it looks like there is a big chunk missing. If you make it a transparent gif, or crop it a little it should do the trick.

-Chris
[/quote]
Done!
Link to post
Share on other sites
OK, now the folder logo is covering up the text logo, and if the dog and tree lights photos weren't bad enough, I just came across "braces girl" and the picture looking up someone's nose. Wonderful.
Link to post
Share on other sites
OK, i think that I fixed the folder logo, I tested it in 1024x786, and my normal resolution:1280x1024, and they looked fine.

I still need some pictures for my content area now (They are just placeholders)...
I like something like this http://photobucket.com/
but I don't want to do that because it will be copying.
Link to post
Share on other sites
If you're not logged in and you try to visit the page to resize an image... (if you know the image #)

[quote]Warning: getimagesize(users//killspiders.gif) [function.getimagesize]: failed to open stream: No such file or directory in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 29

Warning: getimagesize(users//killspiders.gif) [function.getimagesize]: failed to open stream: No such file or directory in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 49

Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 54

Warning: imagecreatefromgif(users//killspiders.gif) [function.imagecreatefromgif]: failed to open stream: No such file or directory in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 59

Warning: imagecopyresized(): supplied argument is not a valid Image resource in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 66

Warning: imagegif(): supplied argument is not a valid Image resource in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 72[/quote]

If you leave out the image # (logged in or out):
[quote]Warning: getimagesize() [function.getimagesize]: Read error! in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 29

Warning: getimagesize() [function.getimagesize]: Read error! in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 49

Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 54

Warning: imagecopyresized(): supplied argument is not a valid Image resource in /home/.marble/ryannaddy/tzfiles.com/resize.php on line 66[/quote]

You shouldn't allow .exe or .php files.

Example of why not: http://tzfiles.com/users/demo/phpinfo.php (need me to explain more, please feel free to ask why this is a big security issue)
.EXE files can contain viruses. It is okay to not let users upload these things. Let them know they can .zip them or whatever.
Link to post
Share on other sites
I did want to allow people to upload them, I just didn't want them to be able to run on the server, I wanted people to have to download them in order for them to work.

I can't figure out how to do this though. I tried to chmod them, It worked, but then the php file wouldn't open in the online editor.

I would like to know how to fix that issue, I made a post about it in the forms:
http://www.phpfreaks.com/forums/index.php/topic,121914.0.html
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.